"Security header is not valid"

I am trying to setup my pro site payments but I am getting this error.

There was a problem setting up the paypal payment:
"Security header is not valid"
Please try again.

  • James Morris

    Hello Mike,

    I hope you are well today.

    This issue is almost always a case of using the wrong API keys for the Mode you are using. For example, if you are using your live production API keys, but you have your site set to Sandbox (test mode) in the WP Admin -> Pro Sites -> Payment Gateways -> PayPal Express -> PayPal Mode setting.

    Can you please verify that you are using the right API keys for the mode you have selected? If you need to test your transactions, you'll need to get a set of developer keys from https://developer.paypal.com/

    I hope this clarifies a bit.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.