Seems incompatible with memcached plugin

Hi,

We have used this plugin for a few years now.

Recently we tried to update our db.php from version 3.1.2 to version 3.2.3

When we upgrade to the latest db.php it does not work with http://wordpress.org/plugins/memcached/

I am not sure if the bug is with your plugin or the memcached plugin, but we didnt have this problem with version 3.1.2 of multi-db.

The php error log returns lines like this when we update multi-db:

PHP message: PHP Warning: Illegal string offset 'widget_calendar' in /var/www/wp/wp-includes/option.php on line 68
PHP message: PHP Warning: Illegal string offset 'post_count' in /var/www/wp/wp-includes/option.php on line 68

No MYSQL querys seem to work and pages do not load.

Can you please advise what steps we can take to fix this?

Thanks

Mark