Select Language at SignUP is almost 5 years old

I'm creating a new international network and Select Language at Signup seems to be a plugin that would fit nicely.

However, this plugin literally hasn't been updated since Dec of 2013 - almost 5 years ago!!!!

Can you please confirm that this plugin is safe to use with WP 4.5? Is it going to continue to be monitored?

I'm running Ubuntu 17.10 with PHP 7.1 and also want to make sure it's compatible with this version of PHP.

Thanks!

Sorry couldn't choose "other" for plugin I need help with!