Selecting Service does not show the correct working hours

Hi guys,

I want to explain the situation. I have several Provider Services as dummy, every service has the time configured. When I try to make an appointment for example for "Reiki" it doen't bring back the correct working hours. I was seeing that que schedule is taking a base from Working Hours at "List For: Provider not specified" It takes this base and not show that I define for service "Reiki" that is associated with X Service provider.

Thanks

  • Rupok
    • Support Ninja

    Hi christian,

    So sorry to hear this. I tried to regenerate this on my test site but I could not. So I think, this is your site specific issue.

    I tried to check the issue on your site with Support Access. But when I tried to access your site, it's showing me the following error:

    Failed to establish a connection to the database

    Can you please check if your database server is working fine?

    Please let us know when your site is accessible again. We will be glad to jump in.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi christian,

    Thanks for confirming. If I understood your query properly, then the issue is, when you are changing the service provider for the service "Relki", it doesn't change the timing for that specific provider, right? If yes, then I could not regenerate this on your site. I've created a video screencast showing the process here: https://monosnap.com/file/XC2YHLeGq8ZCmeEr2vO0CSHZ0VeHZW

    Is this issue resolved already or am I missing anything? Or did I understand your query wrong?

    Please correct me if I'm wrong. We will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • christian
    • Design Lord, Child of Thor

    Hi Rukop,

    yes you're correct, but you have to see the working hours for differents therapist. For example I you select at activity or service "Reiki" and then select a therapist, you will see for example that que working hours that brings at frontend are the working hours belong to "therapist or service provider not specified". Is not bringing the corrrect working hours.

    Example, for service or activity reiki i have define two therapist, one of them I know that Tuesday cannot work, so in her working hours I set NO on tuesday. When I go to Frontend and select reiki activity then this worker i said, the calendar shows me the default working hours or not define provider option.

    You will see that because the tuesday is available and this not to be availble because i set it to NO.

    Try it please.

    Thanks

  • Nithin
    • Support Wizard

    Hi christian,

    Hope you are doing good today. :slight_smile:

    Example, for service or activity reiki i have define two therapist, one of them I know that Tuesday cannot work, so in her working hours I set NO on tuesday. When I go to Frontend and select reiki activity then this worker i said, the calendar shows me the default working hours or not define provider option.

    This is a bug which has been recently reported, ie the working hours specified for each Service provider doesn't reflect in the front end. Only work hours specified in "No Specific Provider" will only work.

    I'm marking this as a bug, so that you get an update when we have a patch ready for this issue. Will keep you posted, once we have a fix ready asap. Have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi christian,

    Hope you are doing good today. :slight_smile:

    Sorry for the delay in getting back to you, this issue should be fixed in the latest version of the Appointments+ plugin ie v 2.1.

    Please test, and let us know if you still have issues. If yes, please do enable support access, and let us know so that we could give a closer look.

    You can check this manual on how to enable support access:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.