sender of message listing twice

Hi! I've been having trouble with the message that appears after sending a message. On the page that comes up post-sending (that is in a temporary "From:SendersName" tab) it says "Conversation between RecipientsName, SendersName and SendersName." I've deactivated all of my plugins except Buddypress, and the error still happens. I then switched over from my current theme (Salutation) to BP Default, and the only difference is that it says "Conversation between RecipientsName, SendersName and you".
Have others encountered this issue before? Is it difficult to fix? Is this a Buddypress/core/functions issue, or can I fix this through editing templates?

  • aecnu

    Greetings astonish,

    Lets start at the top with the exception of deactivating all of your plugins since you have tested that procedure with the exception of Buddy press which may very well be the culprit.

    Picking Salutations and Buddy Press will be a double challenge for you to work with.

    So lets see what we got here:

    WordPress 3.3.1?
    MultiSite or Solo?
    Buddy Press 1.5.5?
    Messaging 1.1.4?

    Have others encountered this issue before?

    Many people have trouble when running Salutations, Thesis, and Genesis - by far the problem children of the themes. I do not know of anyone reporting this specific problem though.

    Is it difficult to fix? Is this a Buddypress/core/functions issue, or can I fix this through editing templates?

    We have not figured out exactly the problem yet so I do not know.

    We have figured out that Salutations is definitely having an effect by your reported troubleshooting above. In addition, though you mentioned going to Buddy Press default theme in this troubleshooting effort, I would like to know if you have tried Twenty Eleven - this is the standard protocol we use in debugging. Please advise of the results from Twenty Eleven.

    As we can see that you can so far manipulate the results by changing themes so I am currently in the belief it is a theme issue. Further testing can confirm this for sure I hope then we can get to work on a possible cure.

    Please advise as the results you get using Twenty Eleven.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

  • astonish

    Hi Joe!

    Looks like it was a buddypress problem, at least for template coding for the theme (or... maybe that is a theme issue.) A fantastic developer that's assisting me found this bug ticket:
    http://buddypress.trac.wordpress.org/changeset/5641

    It was fixed by changing a line in:
    bp-messages/bp-messages-template.php

    Hopefully other people with this issue now can find this thread and easily fix it. :slight_smile:
    Thank you for your great answer!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.