Sending mails even before posting

Hi, I was creating a post, havent even save it yet, and I was receiving emails that a new post was posted on my blog
So not even the images show...
What happens If I want to save this post as draft.
I think the autosave from wordpress is making this being sent

Thanks for your help this is important since Im promoting to suscribe, and if I cant use this plugin then Im loosing the people already sucribed

Thanks

  • Alexander

    Hi @victor_espejo,

    I can confirm that this plugin will only send emails that have a status of published. I've just tested this, and I can't get it to send until I publish a post. Save as draft, and waiting for autosave isn't sending the email. While we're getting this worked out, you can go to "Subscriptions -> Settings" and set to "daily digest" If any posts are made within 24 hours, and email will be sent.

    First, can you confirm that you are using the latest version of this plugin? (2.4.6)

    I suspect there might be a plugin or theme conflict. Maybe something is triggering a save from somewhere else.

    Can you test for this? You can do this by switching to the default theme (TwentyThirteen) and deactivating all your plugins. After this, test the issue as see if anything is different. If it's working, try changing your theme back and testing again. If at this point it's broken, we know it's a theme conflict. If not, start reactivating your plugins and testing as you go along, once it stops working you'll be able to know which plugin is causing a conflict. Once a conflict is identified, we can look into a specific solution for it.

    Let me know what you find out here.

    Best regards,

  • Victor

    Hi Alexander
    Yes I have updated, there was like 2 updates for this plugin in the last week
    I know because some text of the plugin are not translating with the .po file
    so every update I have to open the Confirm-email-template and email-template files
    and translate there the texts.

    When I auto update the files also my -es_ES files on the folder are erased.

    Could not replicate the error with my localhost last night, that was very strange that
    I received the email when I was still building the post.

    Thanks

  • Alexander

    Hi @victor_espejo,

    Instead of retranslating every time, you could keep a backup of the .po file. Then when a new version is released, you can use PoEdit and update the source using a download of the latest version.

    Maybe somehow another plugin published it to fast, or maybe it was accidentally published near the beginning and later you just "updated" it.

    Just let us know if you have any more issues here.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.