SEO Plugin causing styling issues

When I activate the SmartCrawl SEO, it breaks some elements on my theme, on the Slide the text goes to the right, I have this king problem every site, I'm using Elementor Pro, can you help me?

  • Adam Czajczyk
    • Support Gorilla

    Hi Adam

    I hope you're well today and thank you for your question!

    I have checked your site and I could see the issue there (the SmartCrawl is disabled again now) but even though I spent great amount of time with it, I wasn't able to replicate it on my test setup in any way. I tried with Elementor Pro, your child theme and even imported your homepage layout and content and to no luck.

    Furthermore, I didn't find any errors in the browser console on both yours and mine sites and any CSS/JS issues that could be related. This makes me pretty sure that it's more of a "site related" rather than a "general incompatibility" and maybe caused by some specific aspect of configuration.

    I'll need our developers help with this so I have forwarded the case to them and am awaiting their response.

    Please keep an eye on this ticket for further information.

    Kind regards,
    Adam

  • Adam
    • Flash Drive

    Hi Adam,

    Thanks for coming back to me.

    I'm not sure it's site related, it's happening on several sites of mine now... I've disconnected the SmartCrawl for 3 websites so far, and that is only because I've noticed it on those 3. It may well be affecting all the sites across my hub.

    Happy for the developer to call me and share my screen to go through the problems if that makes things easier?

    Kind regards,
    Adam

  • Adam
    • Flash Drive

    Hi there,

    I've allowed it on just 2 of the site I'm experiencing problems, lakesidetimber.co.uk and mamafeelgoods.com - I've attached screenshots of the problems but have disabled the plugin for now as the errors are too much to show on the website, however, feel free to activate them to see them first hand.

  • Predrag Dubajic
    • Support

    Hi Adam,

    Thanks for granting access, I have checked SmartCrawl on your site and I was able to pinpoint the issue to the Automatic Linking option in SmartCrawl > Advanced Settings panel.

    I then did some further tests and I was able to replicate the issue on my installation with OceanWP theme running, so I have created a report for our developers to check this out and see where the conflict is.
    At the moment you can disable Automatic Linking as rest of the SmartCrawl functionality doesn't affect your site.

    Best regards,
    Predrag

  • Adam
    • Flash Drive

    Hi Predrag,

    Thank you for looking into this for me and finding the issue, if you could let me know when it has been resolved so I can add the Auto Linking that would be great. The Auto Linking is a great feature!!

    Any questions please do let me know.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Adam

    I'm sorry for keeping you waiting.

    Our developers are still looking into it and I don't have an ETA on a fix but I've just asked them to update us with a status of the case as soon as possible so please keep an eye on this ticket in case we had any additional information or a "hot fix" for you but also please keep the plugin up to date as the fix will most likely be released as a part of an update.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Adam

    I apologize for keeping you waiting for that long. I just checked with our developers and it turned out that the issue was more complex that it seemed. There'll be fix released for this that should come out with 2.3.1 version of the plugin (I don't have ETA on the release but it should be included in that one).

    Meanwhile, one of our developers will prepare a temporary fix for you so you could use it before there's a release. We'll update you here again regarding that workaround for now, since I got a confirmation of this it should be really soon this time.

    Once again, I'm sorry for keeping you waiting.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Adam

    I just got an update for you.

    I have attached a "patch.zip" file to this post. It contains the patch to the plugin that should solve the issue. It will eventually be included in plugin update in future but meanwhile, would you give it a try?

    To do this, please

    - download the "patch.zip" file and extract it to your local drive
    - access your site via FTP (or e.g. cPanel "File Manager")
    - upload the "autolinks.php" file from inside "patch.zip" to the

    /wp-content/plugins/wpmu-dev-seo/includes/tools

    folder on the server, overwriting existing one there (you might want to make a copy of the original file though, just in case you'd need to get back to it).

    Once it's there, please check if the issue is gone (note: you might need to clear all caches on site and in browser before checking) and let me know here.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.