SEO Tests are working on face of it - but not being recognized in the dashboard

i keep doing an SEO check on the site - i get a result - abut it isn\'t finding its way into my hub report - icon stil greyed out

two screen shots in this folder :

https://www.dropbox.com/sh/o0migxthaqywgvi/AADPeXfZg_3IQ9RgXK7jBxWIa?dl=0

  • Katya Tsihotska

    Hi John

    Hope you're having a great day!

    Let me know, was the SEO Checkup completed successfully?

    I will be able to tell you more about the issue if I'll be able to have a closer look at your site. Could you please grant us temporary support access to your website so we can have a better look at your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Don't forget to let us know here once you'll do this.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi John

    I've checked your site and wasn't able to find any issues or possible causes of the issue with the Hub.

    I also tried to replicate this issue with one of my test WordPress installs, but the Hub works correctly for me.

    Just in case if it's a browser-specific issue, could you please, try to clear your browser cache and check again. And also try to check this with another browser. Here you can find instructions on how to clear browser cache:
    http://www.refreshyourcache.com/en/home/

    Let us know about results.

    Kind regards,
    Katya

  • John

    flushed cache - no change
    different browser - no change

    i am running the hub on 4 sites altogether - the other three are all ok - again - refer you to the screenshots -

    when i run the test it gives me a score of 89 - and some issues are flagged - as usual - when i go to the hub dashboard - i see no change - when i go back to the admin - it looks like i have never run it - happy to give you access to site if that helps ?

  • Katya Tsihotska

    Hi John

    Trust you're having a wonderful weekend!

    I've taken another look at your site and found that you didn't run the "URL crawler" yet. I would like to apologize for that I miss this first time. Thing is, that at the moment SEO tab in the Hub is based mostly on the URL Crawler results. Could you please, run the URL Crawler and check if it'll affect the SEO tab in the Hub. You can run it under the WordPress Dashboard -> SmartCrawl -> Sitemap -> URL Crawler section.

    Let us know if even after the crawling, the SEO tab will stay grey.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi John

    I see now, I've tried to run the URL Crawler on your site, but the page just reloads and nothing happens. I've checked this with my test installation, but the crawler works fine there. So, I suppose that it's a site-specific issue.

    In order to diagnose your issue, I'd request you to perform the two tests mentioned in the following:

    1. Just to make sure no other plugin is causing this, can you please do a plugin conflict test?

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new empty plugins folder
    * Move the plugin folder (ex: wp-smush-pro) you want to test from _plugins to plugins
    * Check if issue still persists, if no, proceed to the next step
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin > Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Let us know about results.

    2. Enable wp debug. To enable WP_DEBUG, change the following line in your wp-config.php file:
    define('WP_DEBUG', false);
    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    Please make sure to add the above code just before the line /* That's all, stop editing! Happy blogging. */

    After this, try to run the URL Crawler (please, note, that you need to run only the URL Crawler, not the SEO Checkup). Then go to /wp-content folder and check if debug.log file is there. If it's there. download it, save as debug.txt and attach to your next reply.

    Also, if it's possible, can you provide us with cPanel/FTP and WordPress login credentials (you can create a temporary admin account for us if you don't want to share your own credentials) so we'll have a closer look at your WordPress installation. You can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -cPanel username
    -cPanel password
    -cPanel login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please, DO NOT post any credentials here, as it's a public forum.

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi John

    Trust you're fine today!

    Thank you for performing the tests. I've checked that too and confirm that nothing changed and nothing was logged into debug.log file. So I decided to reinstall the SmartCrawl. After doing this, I checked both, SEO Checkup and URL Crawler, and both work correctly for me now, so it looks like some of the files or data in the database was corrupted during the previous install.

    As the URL Crawler was successfully completed, could you please, check your Hub and let us know if the SEO tab works now.

    Also, you can move all your plugins back to the plugins folder now and re-activate them if needed.

    Kind regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.