Server Error 500 while adding member

Hi guys,

I tried to use Membership 2. Everything works fine, except the most important part...: adding users to a membership.
What I do:
- I go on "add user"
- I choose an existent user
- I set the membership
On the last page, where I can change some stuff like start and end-date and status, I hit save... then an error 500 comes up:

it says that there is an error while loading the page:
https://matthaeus-augsburg.de/wp-admin/admin.php?page=membership2-add-member&user_id=4

What happened?
It's not so cool to use a plugin that throws Error 500 at the most important part :slight_frown:
I added a screenshot of the last functional page.

Thanks in advance for fast support.
Regards,
Christoph

  • Sajid

    Hi @Christoph,

    Hope you are doing good today :slight_smile:

    I am sorry to hear it did not worked for you as expected on add user page. I tried here on my local install, to make sure its not a bug, it worked just fine for me.

    First of all, please run a quick plugin conflict test as illustrated in getting support manual (flowchart) to rule out this issue.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If you still getting the error, then check for error log (if enabled) and post the error message here (mask user name, full directory path etc.. for security reasons).

    If its not error reporting is not enabled than you can do this by adding following define in wp-config.php file, by replacing define('WP_DEBUG', false);

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Also, let us know your get error when you change date or when you change status ?

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Christoph

    Hi Sajid,

    thanks for the fast reply.
    Of course I checked the plugins and deactivated everything - Error is stil there :wink:.

    And here is the error I get from the error.log:

    [28-Nov-2015 12:03:06 UTC] PHP Warning: Creating default object from empty value in /var/www/vhosts/matthaeus-augsburg.de/httpdocs/wp-content/plugins/membership/app/controller/class-ms-controller-member.php on line 343
    [28-Nov-2015 12:03:06 UTC] PHP Fatal error: Call to undefined method stdClass::save() in /var/www/vhosts/matthaeus-augsburg.de/httpdocs/wp-content/plugins/membership/app/controller/class-ms-controller-member.php on line 346

    Regards,
    Christoph

  • Christoph

    Hey Nastia,

    you're right.... that's it!
    The user - it wasn't me - really already had admin access. Didn't think about that :wink:.
    With a non-admin I also get a proper ID (see screenshot, there's a "0") and everything works fine :slight_smile:
    Great thing :slight_smile:

    Maybe it would be good to catch that error in one of the next plugin updates - quite sure I'm not the only one running into this one :slight_smile:

    Thanks for your help :slight_smile:
    Cheers,
    Christoph

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.