Server error on update of Plugin

Hi,
When I updated the Pop-up plugin I immediately got a Server Error 500 message on my Wordpress back end. I can no longer access the back end of my site.
Can you help?
Thanks
Oli