server had a problem connecting to WPMU DEV: "HTTP Error: 403 "Forbidden""

I am hosting several sites on a reseller account at a2hosting.com. I’ve done the same process each time I create a new client site, and the first WordPress plugin I install is WPMUDEV Dashboard.

But yesterday for the first time ever, I got this error when trying to register my WPMUDEV account with the WPMUDEV Dashboard plugin:

Your server had a problem connecting to WPMU DEV: "HTTP Error: 403 "Forbidden"". Please try again.

If this problem continues, please contact your host with this error message and ask:

"Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?"

A2 support has responded:

It seems that WPMU server is actively denying access from this server. You may review/forward the following from manual CURL request I've pushed directly from the server.

Output:
src4 [~]# curl -v https://premium.wpmudev.org/api/dashboard/v1/
* About to connect() to premium.wpmudev.org port 443 (#0)
*   Trying 104.16.25.10... connected
* Connected to premium.wpmudev.org (104.16.25.10) port 443 (#0)
* Initializing NSS with certpath: sql:disappointed:etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
 CApath: none
* SSL connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
* Server certificate:
* subject: CN=wpmudev.com,OU=COMODO EV Multi-Domain SSL,O="Incsub, LLC",STREET=2500 Action Rd,L=Vestavia,ST=AL,postalCode=35243,C=US,businessCategory=Private Organization,incorporationState=AL,incorporationCountry=US,serialNumber=410-441
* start date: Jul 01 00:00:00 2016 GMT
* expire date: Jul 01 23:59:59 2017 GMT
* common name: wpmudev.com
* issuer: CN=COMODO RSA Extended Validation Secure Server CA,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB
> GET /api/dashboard/v1/ HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.21 Basic ECC zlib/1.2.3 libidn/1.18 libssh2/1.4.2
> Host: premium.wpmudev.org
> Accept: /
>
< HTTP/1.1 403 Forbidden
< Date: Tue, 31 Jan 2017 10:08:22 GMT
< Content-Type: text/html; charset=UTF-8
< Transfer-Encoding: chunked
< Connection: keep-alive
< Set-Cookie: __cfduid=d4696c0918f6c9c13e8e576a4334664b31485857302; expires=Wed, 31-Jan-18 10:08:22 GMT; path=/; domain=.wpmudev.org; HttpOnly
< Cache-Control: max-age=15
< Expires: Tue, 31 Jan 2017 10:08:37 GMT
< X-Frame-Options: SAMEORIGIN
< Server: cloudflare-nginx
< CF-RAY: 329c5cadccf8559a-ORD
<
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8" />
<title>Access Denied!</title>

Please contact them and let them whitelist/unban access for your domain name. You may see IP address for your domain name here: http://leafdns.com/index.cgi?testid=A57DA333
Other than that, CURL/FOPEN is enabled for outgoing connections and there are no refrains on this server.

Here are the credentials you may need to troubleshoot things:

REMOVED CREDS BY STAFF

Thank you!