Server response time

I have been trying to figure out why server response times are always so low (on all my sites) or high I should say.

So for this particular site (pag*******tsllc.com), I upgraded my hosting to see if this was the issue, since it is my busiest site, but that did not change the case. I tried optimizing the best I can and deferring anything that does not break the site.

It seems that when Asset Optimization is enabled it adds almost 2s to the response time.

  • Ash
    • WordPress Hacker

    Hello Nathan

    I can't access the plugins page, I am getting "Sorry, you are not allowed to access this page."

    Would you please enable the plugins menu so that I can enable hummingbird and do some testing?

    Also note that, asset optimization tool will not perform in the staging site as staging site is not publicly accessible which is a requirement of HummingBird. So, we have to do the testing in the live site.

    Have a nice day!

    Cheers,
    Ash

  • Nathan
    • Getting there

    It seems you are not logged in, which is why you are getting that page.

    And if you cannot do testing in staging, I don’t want testing in the live site. This is my clients site and he is using it every day. I cannot turn off plugins on a live site.

  • Nathan
    • Getting there

    So I was able to get a good score. But I have noticed some differences between using Hummingbird test and Google Test.
    I also did not Compress any files, I simply Combined, Defer, and Inline Styles/JS. Since Compressing seems to add server load times.
    Attached are images of differences between Hummingbird and Google.

  • Nithin
    • Support Wizard

    Hi Nathan,

    Terribly sorry for the delay in getting back to you. I'm afraid it seems as the login shared for Staging nor for the live credentials shared have admin access to check how the scores are shown in Hummingbird side.

    I ran a Page Speed test for the live site and I could notice the score as 86 for desktop mode at the moment.

    Please do note that Staging site is in private mode, so Google Page Speed insight results won't work as expected, and would vary.

    Regarding the differences noticed in the Live site, these differences in results would mostly have to do with Object, and Page cache enabled in the Live site.

    If multiple results run within the same time interval, it can serve cache results when it comes to page results.

    Could you please make sure when running a Page Speed test to clear the cache, and object cache couple of times, then load the homepage and then check the results vary or not when compared to Hummingbird, and Google Page Speed results?

    If you still notice anomalies, could you please send us your websites credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.