Services and Working Hours not saving in Appointment+ subsite

Hi there,

I am experiencing an issue being able to save any changes to the default services and working hours screens in the Appointments+ plugin. I am trying to follow your tutorial in setting up Appointments+.

I am currently running WP 4.2.2 with all the latest updates loaded for all WPMUDEV plugins. I have not selected any add-ons within the Appointment+ settings area.

Please could you advise how to add services and change the working hours?

Thanks in advance.
Elliot

  • pxwm
    • WP Core Meltdown

    Hi @Elliot,

    Could you please confirm what happens when you try to save the settings?
    Are you logged in as admin when you try and change the settings?
    Have you any other Wordpress plugins installed?
    Are you using a custom theme or default theme?

    If you have a custom theme or other Wordpress plugins installed then I would suggest you take a full backup of your site them:-

    1) Revert back to a default theme and check if this resolves the problem
    2) Then deactivate any other Wordpress pugins and check if this resolves the problem.

    I hope this helps
    Regards
    SteveB

    • Elliot Charles
      • The Incredible Code Injector

      Hi SteveB,

      Amazing first response ...... thank you.

      In response to your questions:
      Q:Could you please confirm what happens when you try to save the settings?
      A:The values that where displayed on entering the screens are displayed again. The times revert back to what they were and any added services seem not to have saved are the default entry is displayed.

      Q:Are you logged in as admin when you try and change the settings?
      A:I am logged in as the superadmin

      Q:Have you any other Wordpress plugins installed?
      A:Yes, very very few non-WPMUDEV though

      Q:Are you using a custom theme or default theme?
      A:Custom theme from Theme Fusion

      Prior to swapping out themes, backups etc (I appreciate the advice and direction) I will respond to Aicee's request to have a peek inside.

      Thanks SteveB,
      All good wishes.
      Elliot

  • Aicee Taguilaso
    • WordPress Warrior

    Hi there, Elliot!

    @pxwm have already mentioned the first things that I should ask you. Thanks a lot SteveB for hopping in. :slight_smile:

    Also, would you mind enabling support access so we can take a closer look on this?
    You can do that from: Admin Dashboard -> WPMU DEV -> Support -> Support Access Tab
    See https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward to your response to the above questions/suggestions! :slight_smile:

    Regards,
    Aicee

  • Aicee Taguilaso
    • WordPress Warrior

    Hi Elliot!

    No worries! :slight_smile:

    I could confirm the issue on your site as I'm getting "Record could not be saved OR you did not make any changes!" when trying to save new appointment. However, I'm unable to replicate it on my own site.

    Before we do a deeper debugging on this, I suggest you try the basic troubleshooting which SteveB has mentioned.

    Please do a plugin/theme conflict test here by deactivating all other plugins except Appointments+ and try switching to WP default theme. Test again and see if it's working fine. Then, activate the plugins one by one to see if there's any plugin that's causing the issue? See the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    You can also try the method found on the "Tip: " part at the bottom of that page.

    Thanks, Elliot! :slight_smile:

    Regards,
    Aicee

  • Vaughan
    • Support/SLS MockingJay

    Posted from another thread.

    Dear Support/Aicee,

    This is a continuation of the following discussion started yesterday (https://premium.wpmudev.org/forums/topic/services-and-working-hours-not-saving-in-appointment-subsite#post-882624).

    I am still having no success being able to change the working hours in the settings or add a service.

    As recommended I have created a separate staging area for testing, deactivated all plugins (except the WPMUDEV Dashboard and Appointments+ plugins) and deactivated the Theme Fusion theme.

    So on the multisite install, there is WPMUDEV Dashboard, Appointments+ and 2015 Theme.

    I want to try and create a demo site to show off the appointments capabilities (a sales tool for myself).

    I went to the /stylez subsite (cloned via WPMUDEV plugin from mobileappz). I have not tried to change the look and feel yet, I wanted to set up the application first in accordance with some hairstyles, staff, working times etc that i have written up.

    When I make a change on the General Settings area (eg. changing something from "Yes" to "No" that change remains in effect after saving.

    When I try and change a working hour range (say from 9am - 5pm to 10am - 6pm) and then click save ... the refreshed screen returns back to the 9am - 5pm values.

    Similarly, when adding a new service or services in the Setting/Services section, upon saving the screen refreshes to show the single default service which is already there on entering the screen.

    I have tried this on /styles and now on /cafez in order to replicate the issue across subsites. I can confirm the same poor result on both subsites.

    I am on Firefox 38.0.1 on a windows 7 Home laptop with the site hosted at Siteground.

    I had set aside yesterday afternoon and today to set up a sophisticated appointment and would appreciate some help as I am not sure what to do or where to go now.

    I would have expected issues further down the road by incorrect setups, not being able to save a record.

    I would greatly appreciate your support on this issue.

    PS - Prior to deactivating all plugins, all the plugins including Wordpress was all on the latest releases.

    Thanks in advance,
    Elliot

  • Aicee Taguilaso
    • WordPress Warrior

    Hi Elliot,

    I'm really sorry but I'm still getting the invalid access token. :slight_frown:
    Would you please revoke and grant access again?

    Or if you want, you can give us your WP credentials so you won't be bothered revoking/regranting access if we get invalid access token. You can send the credentials here in our private contact form: https://premium.wpmudev.org/contact/
    IMPORTANT: Make sure to select "I have a different question" for the topic and kindly send in the following:

    Subject: "Attn: Aicee"
    -WordPress admin username/password/login url
    -link back to this thread for reference
    -any other relevant urls

    Thanks for your patience on this.

    Regards,
    Aicee

  • Aicee Taguilaso
    • WordPress Warrior

    Hi Elliot!

    Unfortunately, I still can't login with the credentials that you provided (username: zizzzite_staging is not working). Now, I only have 1 attempt to log in. :slight_frown:

    I'm sorry, could you please check again the credentials, and send it again through the above method I posted? Also, please revoke and grant support access again, hoping it would work now.

    In the meantime, could you please check for any error, while you're on the page of adding appointment (if you're using Chrome), please click Inspect Element(F12) > Console tab? Let us know if you're seeing any errors.

    Thanks again!

    Regards,
    Aicee

  • Aicee Taguilaso
    • WordPress Warrior

    Hi Elliot!

    I'm sorry for the delay here. I was away for 4 days. :slight_frown:

    I checked your site for error logs and just found PHP Strict Standards warnings which I believe has no relation to the issue that you are having. Also tried adding some stuff through .htaccess, but still can't fix the issue. With that said, I'll be flagging the SLS support (coding experts) here to check your issue and provide some fix/insights on this.

    Although, they may response slower than normal, I'll keep an eye on this one.
    Thanks for your patience, Elliot!

    Regards,
    Aicee

  • Ash
    • WordPress Hacker

    Hi @Elliot

    Please check now. For some reason, your wp_cache_set and wp_cache_get is not working as intended in your site, so I needed to customize a little.

    Line 319:

    $services = $this->db->get_results("SELECT * FROM " . $this->services_table . " ORDER BY ". esc_sql($order_by) ." " );

    Line 494:

    $work_breaks = $this->db->get_results( $this->db->prepare("SELECT * FROM {$this->wh_table} WHERE worker=%d AND location=%d", $w, $l) );

    I have attached the file here.

    Please note that, this changes will be lost in next update. So it's worth to note down this changes somewhere and apply again after your updates.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Elliot Charles
    • The Incredible Code Injector

    Hi Ash,

    I trust all is well on your side.

    I am reaching out as I have now upgraded to the latest version of the Appointments plugin (v1.5.1). I note that the lines I had to modify in the previous version are now exactly as you have in response above in the appointments.php file. (albeit they have moved from 319 to 329 and 494 to 504).

    I am experiemcing the exact same issue as I was before. New records being added are not being saved. Given I no longer need to change lines 319 and 494, do you have any ideas as to how to fix this issue?

    Thanks in Advance.

  • Elliot Charles
    • The Incredible Code Injector

    Your welcome Ash.

    Although it is working I have noted a dual entry in the dashboard for Appointments+. One references v1.4.7 suggesting an update and the other is v1.5.1 and is deactivated.

    How best would I resolve this or is it to be left alone?

    Please see attachment.

    Regards,
    Will P

  • Elliot Charles
    • The Incredible Code Injector

    Hi Luis,

    Thanks for getting back to me on this. I no longer have 2 instances of Appointment+ and the issue has been resolved through another Appointments+ issue which I can't remember the details off the top of my head.

    This should be considered closed now.

    Kind regards,
    Will

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.