set page as hompeage in Upfront

Hi

Would it be possible to tell me how to set the first page I designed in Upfront as my homepage please?

  • Predrag Dubajic
    • Support

    Hey Donna,

    Hope you had a nice weekend :slight_smile:

    Upfront can have static Home page as other WP themes, so all you need to do is go to Settings > Reading, enabled Static Page option and in first dropdown select your desired home page.

    Let us know if that’s what you wanted to do :slight_smile:

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Donna,

    Thanks for the additional info, if you edited default Home page there will be no option to select it as it’s not created as separate page and it uses your custom page that’s shown when “Your latest posts” option is selected.

    I must say that I’m a bit confused by your question now, if you edited default home page it should already be set as home page.

    Can you explain a bit more what are you looking to do here and what issue are you running into?

    Looking forward to your response :slight_smile:

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Donna,

    I’m sorry but I’m still not sure what exactly are you looking for so could you provide me with some additional info here.

    You mentioned above that you edited default Home page that comes with theme, so this is the page shown on when your site is loaded, correct?

    Now, do you want to change that loading page to different one or you simply want to change URL for the Home menu item and link it to different page, for example yourdomain.com/new-page/?

    With this you’ll end up with your current page when someone goes to your site URL, but once there clicking on Home menu item it will open different page, is that what you want to accomplish?

    Best regards,

    Predrag

  • donna
    • Site Builder, Child of Zeus

    Hi

    Sorry I am completely new to this as you can probably tell! I did edit the default homepage but I have now changed it back so that the loading page is the page that shows up when I go into my live website. When I navigate through the menu however I want this page to show up when I click ‘home’ and at the moment this isn’t happening.

  • Predrag Dubajic
    • Support

    Hi Donna,

    Thanks for the additional info, I believe I understand what's the issue now.

    Looks like your Home menu item doesn't have any URL and that it actually just uses # as placeholder.

    So when you click on it it doesn't go anywhere, it just stays on current page and adds # at the end of URL.

    What you need to do is start Upfront editor, click on your menu element and then settings icon.

    It will open your menu in sidebar so expand your Home element in there, select URL from dropdown and in input field paste your site URL.

    Save your settings and that should be it.

    Let me know if you require additional assistance with this :slight_smile:

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.