set up Appointments+

Hey there! I'm trying to set up Appointments+ and have run into a couple of issues. Here's a breakdown of the issue:

1. I have two locations. One location has one person at it. The other has 4 of us. I've defined the services and the service providers and i've assigned them to different locations.

When I try to make a front-end user-calendar specifically for the two different locations, I can do so successfully for the location that has one practitioner at it. For the other location, I'm having trouble. Even though the treatment options are assigned to a different location (and therefore do not show as a selectable option), the system is showing the availability for the other location. (ie, we have 15 minute sessions available at the single-practitioner location, and not the multi-practitioner location.

so even when the front-end calendar isn't giving the option to choose a 15 min treatment in the dropdown menu, the 15 min availability is being loaded into the calendar). This can be "fixed" by simply hitting the "show available times" button. I would prefer that it didn't require this.... And

2. then I have another issue - On the multi-practitioner location, I can't toggle between practitioners for different availability. It only works for one practitioner - the one that is loaded first. If I try to change, it comes back with an error message after 30 seconds that says it's timed out and cannot complete the request.

    Tyler Postle

    Hey Drew,

    Hope your weekend is going well so far!

    1. I've confirmed your first issue. I'm also getting odd schedule behaviour when using locations linked to services. I'm reporting this to the developer so we can get that sorted out.

    2. I see that happening on your install but I'm unable to replicate it on my own.

    As a temporary solution you can try increasing your timeout by following this post: https://premium.wpmudev.org/blog/increase-memory-limit/

    The extra memory wouldn't hurt either.

    The real issue is why is it taking so long to load. Could you send your FTP in so we can investigate further? It seems like it may be a server related problem.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Look forward to hearing back!

    Cheers,
    Tyler

      Tyler Postle

      Hey Drew,

      No problem. Sorry for the delay!

      I just tried increasing your timeout limit; however, looks like your host doesn't allow manually increasing that as it didn't take affect. Could you contact your host and ask them to increase your max_execution_limit - preferably to at least 90 seconds.

      That should resolve the fatal error issue, I spoke to one of our developers and they explained that the tetris add-on can add quite a bit of overhead since it adds more customization.

      As for your first issue, our developer is still investigating that and one of us will reply back here once he's figured out the problem.

      Cheers,
      Tyler

    Drew

    This is what they said:

    Thank you for contacting Hostgator. Unfortunately max_execution_time cannot be increased above 30 seconds on Shared servers. More information about the limits on PHP settings is available here:

    http://support.hostgator.com/articles/pre-sales-policies/php-settings-that-cannot-be-changed

    If you require an environment without this restriction you will need to consider purchasing a VPS or dedicated server. Please let us know if you have any questions.

    Best regards,

    Samuel M.
    Linux Systems Administrator

    -----

    Guys is there any other way? I'm running out of time to get this system up and running. I have an absolute maximum of 10 days left before I need a fully operational system. Also, if it's going to take longer than 30 seconds for the booking plugin to load information, I don't think I can work with that as people will stop using it. If you can think of any other solutions I'd be greatly appreciative.

    Thank you.

    Drew

    Hey Tyler,
    I'm trying to figure out a work around but I'm noticing another issue. I've only got a few days left to figure this out so I need your assistance asap please.
    There is only one practitioner where the "exceptions" are working. My team member Daniela's profile is working fine and the front-end booking works smoothly and shows her available and unavailable days.
    When I set up my own availability at our other location, the exceptions never work and my individual availability gets mixed with the open hours of the clinic, which allows people to book with me when I'm not actually at the clinic. Combined with the exceptions not working, this creates a problem.
    I look forward to hearing from you and hopefully you have a fix for me.

    Panos

    Hi Drew ,

    Regarding the issue where it displays wrong providers when no service is selected I could also replicate. Thanks for noticing and reporting it

    Could you please replace file
    wp-content\plugins\appointments\includes\pro\includes\addons\app-locations-service_locations.php
    with the one attached here? It is zipped so you'll need to unzip it before uploading it.

    As for the time out, I notice you have the Padding add-on enabled. This will add to load time since it does more calculations and db requests so your server may timeout. If it continues to timeout and you can't increase memory limit and max execution time I would suggest to de-activate this addon.

    I would also recommend to keep only one calendar per page. I noticed in one page there are two calendars and this is adding more load to you server resources.

    Please let us know how it goes!

    Thanks!

    Drew

    Hey again.
    I've made individual appointment pages.
    And i'm testing it all and some other things are coming up -

    - I cannot add Padding to any of the appointments that have a shared resource. So I've removed that add-on for now in an effort to speed it up. It was working for our team member who has her own room resource (different location). This is something I really need to function well, as I will have to add those cushions in manually for now, which is far too time consuming for the long-term.

    - on each of the individual pages for our appointments, I have to select a service manually (set to autorefresh), because if I do not, I go through the steps to book an appointment and the first service in the system becomes the one booked - even when that particular service is not allocated to the practitioner that has been selected (calendar displaying), and even when that service isn't available at that location. As the live example a 45 minute session is our first service in the service list and is only available with Daniela at our second location. Even when I'm looking at my calendar and the only options are 60, 90 and 120 minute treatments, if I don't change the selection in that dropdown menu, when I go to book, the appointment in the "confirmation" section is a "45 minute session). And I'm at a different location, and I don't have a 45 minute session as part of my listed services. Not only is this tricky to navigate for a service standpoint and client expectation, this is an issue because if I have someone attempting to book a 60 minute treatment with me, and 60 minutes is the auto appointment selected in the dropdown menu, it will not autorefresh when I select it again. I have to select a different service (eg, 90 minute treatment), and then go back after the screen reloads and select the 60 minute appointment again for it to show the real 60 minute availability for me at my location. ((screen shot attached of an example of this with Chris's schedule)). I'm currently trying to work around it by having the services listed in reverse order, from longest to shortest as the longer appointments are booked less frequently, however this will only be a temporary work-around as we will for sure encounter issues when someone actually does want to book a longer appointment.

    - Appointments are only blocked off for shared resources when they are confirmed. eg. When someone books with me, that appointment time is still available on the rest of my teams calendars (who share the same resource with me) until I confirm the appointment. This creates the opportunity for double-booking if we don't get to approve the appointment right away (taking away the benefit of being able to approve appointments manually). It would be very helpful to have the appointments blocked off on a shared resource as it does for our individual calendars.

    - Google calendar synchronization is not working both ways. It deposits the appointments in my calendar, but it won't pull any blocked off time (eg, half day) from the calendar, even when I have it set to sync both ways.

    I'm able to make it function for now but it's less than ideal, and quite a lot of extra work for me to monitor and stay on top of. Please let me know how to fix this more permanently. Thank you!

    Drew

    Hey guys -
    Please send me an update when you can. Appointments+ is still taking way too long and my business is suffering as a result with less than half the normal number of appointments being booked. Today it took over a minute to load my personal availability once I selected the treatment duration from the dropdown menu.
    If this can't be fixed soon I'm going to have to find another system.
    Thanks,
    Drew.