Set Up Classifieds Plugin

Hi I am very new to Wordpress so still finding my way around - I am running the Classifieds plugin on Wordpress - its set up for pages rather than posts - as a test its free to post your ads - they are all set to be moderated first - I followed the listing process open a new account and add a classified - then publish through admin - however I cannot view the published ads anywhere in the public domain - if I log in I can only see the add posted by that user but not any ads by other users - I guess I have something wrong in the basic set up when you go to this page: http://www.swapaset.co.uk/news/classifieds/ I expected to see all the posted ads - but there is nothing there - I would appreciate a little advice and guidance many thanks AG

  • aecnu
    • WP Unicorn

    Greetings AG,

    Thank you for bringing this item to our attention.

    I have indeed visited your site and as you have indicated the classifieds do not appear there.

    I have also noticed that the slug URL has been changed as well.

    With that in mind have you reset your permalinks by any chance?

    For permalinks have you chosen anything but the default choice?

    Where did you change the Classifieds slug or are you using short codes?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings AG,

    On a side note that I just noticed, our system reports your installation is several versions behind, 4 to be precise.

    It is in your own best interest to update to the newest version to avoid as much grief as possible.

    Please advise.

    Cheers, Joe

  • arcaneagenda
    • WPMU DEV Initiate

    Hi Joe, thanks for coming back to me so quickly - yes I have changed the permalinks to:
    Post name: http://www.swapaset.co.uk/news/sample-post/
    as I would like user friendly urls -
    when you do this the classifieds permalink atomatically becomes
    Permalink: http://www.swapaset.co.uk/news/classifieds/

    If I change back to default permalink it gives page not found

    I changed the tab name back to Classifieds just by editing the page title

    I updated the Classifieds version to most recent as well -

    Appreciate your further thoughts

    Thanks again

  • aecnu
    • WP Unicorn

    Greetings AG,

    Thank you for the additional input.

    We certainly do not want to be using the default, permalinks because most stuff is broken using the default permalink setting.

    However, I have had another possibility brought to my attention.

    Please while logged in as network admin go to --> Custom Press --> Settings --> make note of the Post Types and the new selection Classifieds.

    Please un-check default and check Classifieds for each type and let me know if this indeed resolves the public viewing issue.

    Please advise.

    Cheers, Joe

  • arcaneagenda
    • WPMU DEV Initiate

    Thanks Joe, I havent been using custom press at all - so not sure if the settings are over riding word press - I looked in the settings for CPress all were set to default -
    I unchecked default and changed everything to Classified - then saved and went back to check the save it updated ok - but no change on seeing the ads -
    would it help if I set up an admin account for you - if so, please let me know where to send the details
    Thanks

  • aecnu
    • WP Unicorn

    Greetings AG,

    Something is certainly amiss there and as you can see I have no problem on my productions servers bringing this up at all:
    http://classifieds.aecnuwpmu.us/classifieds/

    Now it is time to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings AG,

    Thank you for the additional input, it is greatly appreciated.

    Note: that the system indicates you are one version behind in your Classifieds installation, please update to version 2.3.0.5 at your earliest convenience if you have not done so already.

    It is my opinion that tt is something with the URL's/Slugs and/or permalinks.

    This WordPress installation is indeed a full install in the news sub folder?

    Please advise.

    Cheers, Joe

  • arcaneagenda
    • WPMU DEV Initiate

    Hi Joe, thanks for the advice - Arnold got involved via another thread saw the issues and offered this advice:

    "You do look like you have a problem with permalinks not working properly. Try this.
    Go to CustomPress > Content Types > Post Types and delete the "classifieds" post type. Then go to PLugins and deactivete and reactivate the Classifieds plugin"

    I followed the instructions and I am pleased to say the adverts now display on the page - thanks again for all your help - for now this thread can be closed -
    Cheers AG

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.