Setting button anchor tag jumping to top instead of opening the menu

The settings button on the Members profile page just scrolls to the top of the page instead of opening the menu. I am using the Ultimate Member plugin.

https://******ablyin.com/user/+++++dalice/

It works if you open chrome console with ctrl+shift+J first though.

  • Adam Czajczyk
    • Support Gorilla

    Hello Tarun,

    I hope you’re well today and thank you for your question!

    I tried to access your site to check it but I wasn’t able to, I was getting an error when trying to use support access that you apparently enabled. That, unfortunately, happens sometimes and usually re-grating support access help.

    Could you please go to “WPMU DEV -> Support” page in your site’s back-end, revoke and then re-grant support access again? Let me know here once it’s done, please.

    Also, if there are any additional login security tools (except e.g. our own Defender), please disable them temporarily.

    There’s also a support forum on UltimateMamber site so I think it would be worth asking about the issue there https://ultimatemember.com/support/

    Did you already try it?

    Best regards,

    Adam

  • Tarun Thadani
    • WPMU DEV Initiate

    Hi,

    Sorry the wpmudev plugin got removed as i cloned the site back from the original fashionablyin.info in which everything seems to be working fine. You now have access.

    Its just when i moved everything here the problems started.

    The problem seems to be with

    .um {

    opacity: 1 !important;

    }

    I have tried adding this snipet only on the pages required with add custom css plugin and it has helped but still the profile settings are not available properly.

    However when you change you window size it works…

    Very strange problems, really need your help!

  • Adam Czajczyk
    • Support Gorilla

    Hello Tarun!

    Thanks for enabling access. I was able to check the site this time and I could see the issue in action.

    I did try to add/remove your CSS code but it doesn’t seem to take any effect. It looks to me like for some reason the JS code that’s casing that drop-down menu to show is not properly executed in a “full size” (not mobile) view. I’m not sure tho why that is.

    You mentioned that this is the copy of the fashionablyin.info site where the same feature works fine, right? Are there any differences between the configuration of these sites or are the exact copies?

    Would you mind enabling support access to the original one so I could check it too and compare them? That might help :slight_smile:

    Also, I would really recommend asking on UltimateMembers forum as well. There’s a chance that somebody there already encountered this (or very similar) issue and might be of help.

    Best regards,

    Adam

  • Predrag Dubajic
    • Support

    Hi Tarun,

    I had a look at your site and the settings button is opening properly dropdown properly on both .info and .com sites so this is now working properly, right?

    If I understand correctly the issue is now with the page content being cut down by page height, is that correct?

    This issue seems to be caused by some of the scripts on your site, most likely from theme, that calculates wrong page height and it set’s it to 566 pixels which is not enough to fit the entire content.

    You could try applying quick fix with some CSS like this one:

    .um-page-user.um-page-loggedin #main {
    height: auto!important;
    }

    However I would suggest performing a conflict test by disabling your plugins and switching to default WP theme to see what exactly is causing it and then get in touch with theme/plugin developers about this issue.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.