Setting up Domains for Wordpress MU with Plesk Server (1and1 dedicated)

Okay, so I'm running a plesk dedicated linux server.

I'm new to this whole Wordpress MU and can't help to feel that the manual that you folks provide isn't quite adequate enough for my situation.

I had copied over my newly dloaded wp3.1 files and ran the web script installation to bring it active.
I've tried to add define(‘WP_ALLOW_MULTISITE’, true); to the wp-config file as instructed to do so at https://premium.wpmudev.org/wpmu-and-buddypress-installation/creating-a-network-by-enabling-wordpress-multisite/) and I didn't see a "Network"option appear under Tools in the wp admin area. How come? I made sure I saved the changes. am I missing something here?

Does anyone have experience in setting up a Wordpress MU on a 1and1 dedicated (plesk) server?

I have access via ssh (putty) and I was going to follow these rules to setup a wildcard domain
http://codex.wordpress.org/Configuring_Wildcard_Subdomains_for_multi_site_under_Plesk_Control_Panel
but the question is do I need to? What are the advantages/disadvantage. I'm planning to create several subdomains for a signal site.

Thanks!

  • Mason

    Hiya Madburner,

    If you're going to run multi-site with subdomains (as opposed to sub-directories) then yes, you need to activate the wildcard subdomains.

    Whether running on plesk, cPanel, or other - the process for enabling Network is the same - it's just a define in the wp-config.php. Do you have WordPress single-site up and runnign smoothly?

    Did you make sure you're not using the curly quotes in your wp-config file? Try manually typing it in with single quotes like 'this' rather than copying/pasting. Sometimes that thows things off.

    Let us know.

    Thanks!

  • Anthony

    @foodfriendfinder, are u referring to my browser cache, if so I cleared it 1000x and also have it disabled in FF.

    @masonjames, that seems to do the trick, but now when I try to follow the given instructions on the WP codex site about setting up a wildcard domain

    Instructions for preserving web-based email with WordPress wildcard-subdomains
    Follow these steps -

    In your hosting root folder /etc/httpd/conf.d/ locate the following files at the bottom of the file list -
    zz010_psa_httpd.conf - this contains the domain and subdomain name loading order controls for your domain.
    zzz_atmail_vhost.conf - this contains the domain and subdomain name loading order controls for the AtMail browser based webmail software.
    zzz_horde_vhost.conf - this contains the domain and subdomain name loading order controls for the Horde browser based webmail software.
    Note the file naming conventions - they are loaded and run by the server in alphanumerical filename sequence, and it is this that causes the loss of webmail access when enabling wildcard subdomains. You might also have files for RoundCube and other browser email software - do the same procedure with them.
    Rename the two (or more) mail service files as follows -
    Rename zzz_atmail_vhost.conf to zz001_atmail_vhost.conf
    Rename zzz_horde_vhost.conf to zz002_horde_vhost.conf
    Restart the Apache server service (if you have root access, it is in Plesk Panel Home screen - Server - Server Services Manager, just click the restart button and wait 30 seconds).
    This will place the mail host names, and their associated wildcard mail-user names (shown in DNS), above and before the website domain and subdomain names in the loading sequence.

    I can't seem to find those file even with root access and I don't see the mentioned folder or complete path names. Does anyone have experience in this that could lend a hand, I would greatly appreciate it. Thanks thus far for everyone's help

  • Anthony

    I already indicated where the codex page is in my initial post but just in case you missed it, it's
    http://codex.wordpress.org/Configuring_Wildcard_Subdomains_for_multi_site_under_Plesk_Control_Panel

    I'm trying to figure out how to find the files on server.
    zz010_psa_httpd.conf
    zzz_horde_vhost.conf

    I tried to follow the instructions but I can't locate those files. Anyone know where to find it?

  • Timothy Bowers

    I'm not overly familiar with PLESK, never really liked it and found it rather awkward so please forgive my ignorant reply, I much prefer cPanel.

    Anyway, Horde is an email script for accessing an email accounts over http, I presume this is what the file refers to unless PLESK names something else Horde which could be confusing. If it is then perhaps your installation doesn't have Horde installed? But if it is:

    /etc/httpd/conf.d/zzz_horde_vhost.conf

    With regards to the file "zz010_psa_httpd.conf: I note form the following link:

    http://forum.parallels.com/showthread.php?t=65587

    This file is handled by Plesk, thus every change you make will be overwritten every time you make a change in Plesk.

    File location I believe is:

    /etc/apache2/conf.d/zz010_psa_httpd.conf

    Does anyone have experience in setting up a Wordpress MU on a 1and1 dedicated (plesk) server?

    Unfortunately I do... We use to have some servers with them a few years ago (before they stuck PLESK on them) I went grey and so we took what servers we had with them and moved to UK based datacentres, I remember the parties we had afterwards fondly. :wink: They once chased us for some several months for a fictional bill relating to a service we cancelled with them, they tried taking us to court despite providing proof of our correspondence and cancellation. They failed, no one can argue with proof.

    Here is my experience, the main server hosting the MU installation had a bloated install and around 2 am onwards every morning (GMT) the server would be brought to its knees and at the time we didn't have a sys admin because 1and1 provided the servers managed. They were unable to locate the problem and on one occasion whilst speaking to their technical support I had to google a problem and provide them with the fix all because they would not permit me root access on a managed server at the time so I couldn't do it myself.

    Whilst things are running smoothly all will be well though. :slight_smile:

    Anyway, if you can't find the files on those paths I indicated above then perhaps try asking Parallels direct or ask OneAndOne for some help. As I said perhaps Horde isn't installed on your server?

  • Mason

    Sheesh. Tim, that's a terrible story.

    I've had two (brief) encounters with Plesk - and neither were any fun. Fortunately I haven't had to dive into this level of configuration - though Madburner, I know that doesn't help you.

    Ultimately, I do think you're best approach here is going to be to contact your host provider. They should easily be able to point you to the exact files you need (or if something needs to be added/installed).

    If you're able to get a response from them, we'd love to hear what the solution ends up being as I'm sure others will encounter the same difficulty.

    thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.