Setting up Multisite on Linux Shared Hosting

Hello!

I have installed Domain Mapping plugin on my website along with Pro Sites and a few others. After creating new site when I tried to add new domain to my site it gave me the error shown in the attached screenshot. It is showing the same error for any domain.

  • Adam Czajczyk

    Hello SAntosh,

    I hope you're well today and thank you for your question!

    In order to map a domain to any of Multisite sub-sites you will first want to setup this domain to point to your server. This can be done a few different ways:

    1. If your Multisite setup is using a dedicated IP

    For each of the domains that you wish to map, the A record should point to that IP. Additionaly, if the domain is parked (or added as "addon domani") on your server, its root folder should be set to the same folder as root folder for your main domain

    2. If your Multisite setup is not using a dedicated (fixed) IP

    An option is to set CNAME record in DNS for each domain that's to be mapped to point to your main domain. For example:

    - mapped.com is the domain about to be mapped
    - main.com is were you main site of your Multisite network currently resides
    - CNAME record for mapped.com should be set to main.com

    In both cases as a result typing a domain that's about to be mapped into the browser bar should result in loading the main site of your MultiSite network. When this works, you then should be able to add that domain to Domain Mapping.

    Please check those settings and let me know if it helped!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.