Settings -> Mapped Domains is empty

I've been banging my head agains the wall for a few days on this but I can't seem to get Domain Mapping to work. I've tried various configurations over the last week so I may have messed up some settings somewhere in the overall stack.

I want to get Multisite + Pro Sites + Enom + Paypal all working together and frankly I can't describe the actual problem I am having because I don't know what the problem is other than when I go to Settings -> Domain Mapping there are no sites in that pane according to this tutorial I have been trying to follow...

https://premium.wpmudev.org/blog/wordpress-multisite-wordpress-nginx/

I have activated Support Staff Access to https://la.renta.net if someone would be good enough to have a look. Thanks.

  • markc

    As far as replying is concerned, I was accessing this support page from within my wordpress dashboard and it seems that the premium.wpmudev.org does not consider that I am logged in so does not show any Reply links. Now I have gone directly to wpmudev.org and specifically logged in I now get a Reply link. That is not very intuitive. Anyway, to continue with this... thread, ticket, whatever you call it.

    When I attempt to go to my first subsite to do what you suggest all I get is "The page isn't redirecting properly" so I cannot access the Subsite Admin > Tools > Domain Mapping area. How do I proceed in this case?

  • markc

    As I mentioned in my first post, I am following this tutorial...

    https://premium.wpmudev.org/blog/wordpress-multisite-wordpress-nginx/

    where the only variations on the above are that my nginx.conf root is /home/u/la.renta.net/var/www instead of /var/www/wordpress and I only recently obtained a SSL certificate (after initial setup) and I am using subpaths instead of subsites.

    Just now I disabled all my plugins and changed my /etc/php5/fpm/php.ini cgi.fix_pathinfo setting to zero to see if that helps... and edited the database directly to change any http URLs to https.

  • markc

    This is my first and only (so far) subsite and as you can see it cannot find all it's assets. This may depend on the rewrite rules for nginx but I have followed the above tutorial pretty well to the letter except for the nginx root path setting and adding SSL (which is not included in the original tutorial)...

    https://la.renta.net/illareencom/

    When I go to...

    https://la.renta.net/illareencom/wp-admin/

    I get the "The page isn't redirecting properly" error so therefor I can't get to the subsites admin page to be able to add it to the domain mapper. Catch 22 I guess.

    Oh yeah, this is a Ubuntu 14.10 setup with their nginx-full 1.6.2 package and php5-fpm 5.5.12, plus MariaDB.

    Could someone please advise me what the absolute minimum but necessary plugins to enable for Multisite + Pro Site + Doman Mapping + Enom + Paypal?

  • Ash

    Hello @markc

    Well, in your dashboard you just open a support ticket, no way to reply. To reply you mush login at WPMU site and reply there.

    # Please avoid frequent posting in a thread before a staff reply. We process threads in a queue, and when you reply double (bump) your thread will be pushed back to queue again. Luckily this time, I saw this thread :slight_smile:

    # Please create multiple tickets for multiple topics. Do not bring different issues in one single thread. This way, the threads will be categorized, easy to maintain and reply :slight_smile:

    Now about your redirect issue, I have just remotely logged in at your site and I could access the subsite admin page, screenshot attached. Would you please try deleting browser cache or even in another browser?

    Could someone please advise me what the absolute minimum but necessary plugins to enable for Multisite + Pro Site + Doman Mapping + Enom + Paypal?

    Would you please create a new thread explaining your plan or what exactly you want to achieve? We will try to give you some suggestions.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • markc

    Yep, thanks for your advice on this issue system.

    Just repeating that it is not very intuitive to have a support area in the dashboard that does not work for replies and no hint or suggestion that I should instead log directly into wpmudev.org. I was unnecessarily confused and frustrated.

    The reason that subpath site now shows up is because I had to read through all of the rtCamp documentation on nginx and finally found a nginx config snippet that started to work. This is the advice I was hoping to get from you guys ...

    # /etc/nginx/conf.d/wordpress-mu.conf
    #
    # This section does (seem to) work for MU subpaths
       if (!-e $request_filename) {
        rewrite /wp-admin$ $scheme://$host$uri/ permanent;
        rewrite ^(/[^/]+)?(/wp-.*) $2 last;
        rewrite ^(/[^/]+)?(/.*\.php) $2 last;
      }
    
      location / {
        try_files $uri $uri/ /index.php?$args ;
      }
    
    # From https://premium.wpmudev.org/blog/wordpress-multisite-wordpress-nginx/
    # This does NOT work for a MU subpaths
    #  location / {
    #    try_files $uri $uri/ /index.php?$args;
    #  }
    

    BTW and FWIW the code backticks on this system did not work above. I had to manually change the backticks to pre tags for the monospaced config example. However the "code backticks" in this paragraph does work so something in my code snippet must have disabled the backticks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.