Severe performance issues with Custom Sidebars Plugin

Starting on Monday my website became crippled by lag. I ran the P3 Plugin Profiler and it turns out the culprit is the Custom Sidebars Plugin. I run a very large site (www.dmu.edu) with many many sidebars so I thought that was the cause, even after deleting all sidebars the plugin continues to cripple my site. It is only operating now because of W3 Total Cache which is serving static versions of the website.

I also tried upgrading to Custom Sidebars Pro but that had no effect.

  • Tyler Postle

    Hey Seth,

    Hope you're doing well today and welcome to the WPMU DEV Community!

    So it was fine up until Monday? We did release an update on Monday; I am wondering if perhaps that had something to do with it. Sounds like it started happening before that, did you add any new plugins or update anything else that day?

    Do you have a development setup to run tests for your site?

    Look forward to hearing back on this Seth!

    All the best,
    Tyler

  • Michelle Shull

    Hi, Seth!

    To confirm, did you see a significant gain in load time with Custom Sidebars Pro deactivated, or are you basing your question on the results of P3 only?

    I don't recall seeing a similar issue on the forums, and I'm not seeing a big difference in my sights with Custom Sidebars installed when I deactivate that plugin, so I think we might do well to do a little troubleshooting here to confirm this is an issue solely with Custom Sidebars.

    With Custom Sidebars disabled, what's the next highest plugin on the P3 list?

    Have you tested your site with a default WP theme, to see if maybe the issue is with your theme attempting to load the sidebars?

    Have you used any external page speed tests, like YSlow, to see if they reveal more clues?

    Thanks so much, Seth!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.