Share count issue - I can't solve it!

Hello.

My website has a severe share count issue...and we are trying to solve it without success since a week or so...

Several posts show all the same amount of shares - it seems they take the share count from the homepage!

We couldn't find a solution, so we asked our host woengine. Thy said its related to our theme, and that this code could be messing the share count http://cl.ly/image/1j1q0o2c3s0z

The theme developer took a look, but said their code is ok. He debugged a few posts with the facebook debug tool. Theres posts now start with the share count from zero (...this post for example was debugged http://thrivethemes.com/forums/topic/share-count-issue/)

But all our new posts still have the problem: they draw their shares from the homepage! Here a few examples of posts that have all the facebook likes from the homepage: http://www.krisstelljes.de/reich-werden/ or also this one http://www.krisstelljes.de/ueberschriften-erstellen/

If anyone has experience with this kind of problem, we would be SUPER GRACEFUL if you can help us to find what is causing this error, and how we can stop it from happening in future. I already granted access to the site.

Thank you in advance for your help!

  • Michael Bissett

    Hey @Julius, hope you're doing well today! :slight_smile:

    Doing a bit of investigating here, and inside of:

    Settings -> Tweet Like Plusone

    I tried checking the box for "Do not add Facebook OG META tags" in the "Other options" section at the bottom of that page.

    After doing so, I tried creating a test post, and found that the like & share counts both started off at 0 for me, so it looks like it's working as it should so far. I should note, that in the process of looking into this:

    - I did clear WP Engine's cache for your site
    - I did also do a debugging of this post using Facebook's Object Debugger:

    http://www.krisstelljes.de/ueberschriften-erstellen/

    Could you try creating a new post of your own, and seeing if it works as it should now? :slight_smile:

    Please advise,
    Michael

    P.S. I've marked my test post as Private, please feel free to delete that. :slight_smile:

  • Julius

    Hi Michael,

    thanks a lot for your help!

    It looks like this solved the problem.... ufff.... spent hours before to research the error....

    What is still strange: I had to debug also some older posts, that had a regular share count first (and got messed up later). After debugging they also show "0" shares now... You think this can be normal due to this issue?

    In any case, thx a lot for helping us find the solution!

  • Adam Czajczyk

    Hey Julius,

    I hope you're well today!

    It's good to know that the solution worked for you. As for FB debug on older posts - it's quite possible that doing this did reset those counters. Actually, it's quite common that there has to be some FB "debugging" done (it happens a lot for example after the featured image change) and the procedure is meant to, among other things, clear FB's caches. That said, it may also clear counters.

    I hope however, that since the solution is working for you there'll be no need to play with "FB debugging" anymore :slight_smile: If you have any further questions on this or need any assistance, please let me know. I'll be glad to help!

    Cheers,
    Adam

  • Julius

    Hi... Its kind of mysterious, but we still have the issue on the site (again).
    Just spend an hour or so again to find the issue, without success.

    A few of the latest posts we pulished have the share count from the homepage again. And even most of the planned posts that are in draft mode take their social count from the homepage. We really dont know where this does come from.

    If anyone finds a few minutes to take a look at the site, this would be great!
    Maybe you see whats causing this issue?

  • Michael Bissett

    Hey @Julius! :slight_smile:

    As a quick test, could you try disabling the other plugins on your site (aside from the sharing widget), and then trying to publish another post, and seeing if the share/like count is the same?

    I'm still seeing that using the Facebook debugger gets the share/like count to be what it should, but I'm curious as to why the home page is being looked to in the first place...

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.