Shared Resources not working

Enabling shared resources add-on, under Appointments > Settings > Add-ons, makes all the time slot as busy, even for services not marked as shared.