Shipping Applied with Charge Shipping NOT Selected

I'm launching a new store and just noticed that shipping is being applied to a product, even though I have left the Charge Shipping box deselected for the product.

The item is available for in-store pickup only. So I leave Charge Shipping unchecked, and the default base shipping rate gets applied. I tried entering a negative value for the Extra Shipping Cost but that is not allowed.

Dev site with product in question is still available (for now) at http://kitchen.pieoneer.com/store/products/take-bake-pie/ and Support Access has been granted.

Any help or suggestions is greatly appreciated!

On a related note, is there any way to offer In Store Pickup Option, when using Flat Rate shipping? The option only appears when selecting Calculated Shipping. The USPS system is clearly not working though, and my client needs to offer Flat Rate Shipping AND In Store Pickup. With the Charge Shipping issue I describe above, this is turning out to be quite a challenge!

  • Adam Czajczyk

    Hello jcnjr,

    I hope you're well today and thank you for your question!

    The "Pickup" (e.g. "In store") option can only be applied in case of "Calculated Options" Shipping Method.

    In case of "Flat Rate" shipping there's no such option so a workaround could be to set shipping price there to "0" and then use "Extra Shipping Cost" for each product. I think however that would be quite an inconvenient and not much reliable way so I'm just mentioning it as a "last chance resort" kind of workaround.

    That said, I have checked that on my own setup and I can confirm that with a "Flat Rate" shipping even if "Charge shipping" option for a product is disabled, the standard shipping rate is added. I consider this a bug so I filled a bug report for developers and hopefully they'll be able to give us a helping hand here.

    Please note however that their response time may be a bit longer than mine here on support forum as they deal with a lot of complex issues at once.

    Please keep track of this thread and I'll update it once I get a replay.

    Best regards,
    Adam

  • jcnjr

    Thanks for the quick reply @adamczajczyk

    ...workaround could be to set shipping price there to "0" and then use "Extra Shipping Cost" for each product.

    I considered this, but it is not only incredibly inconvenient, it does not allow for flat rates to be applied for Lower 48, HI & AK, Canada and International.

    I consider this a bug so I filled a bug report for developers

    I do too, thanks for confirming the issue.

    ...response time may be a bit longer than mine here on support forum as they deal with a lot of complex issues at once.

    Understood, looking forward to that variations issue, and happy to help test any fixes in the works!

    In the mean time, does anyone know if there might be a quick hack to allow negative integers in the Additional Shipping fee, that might be used without throwing the error to subtract the base shipping rate?

    Thanks again for the great support...

  • Adam Czajczyk

    Hello jcnr,

    Thanks for your replay!

    In the mean time, does anyone know if there might be a quick hack to allow negative integers in the Additional Shipping fee, that might be used without throwing the error to subtract the base shipping rate?

    I don't that'd be an easy workaround, unfortunately. Although database/PHP script would of course allow negative integers, I suppose this wouldn't go properly through all the MarketPress filters as if not that bug - the negative shipping prices shouldn't even be considered. I think we'll need to wait for developers response then.

    Please keep an eye on this thread and I'll update it as soon as I get a replay.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.