Short code – unexpected results

I set up 2 services with 2 service providers

Created 2 pages one for each

Inserted the following codes on one page

[app_my_appointments]

[app_monthly_schedule service=”1″ worker=”260″]

[app_pagination month=”1″]

[app_confirmation]

[app_login]

And this on the other

[app_my_appointments]

[app_monthly_schedule service=”2″ worker=”4″]

[app_pagination month=”1″]

[app_confirmation]

[app_login]

However no mater which page I am on I get only one calendar and confirmation form that is service 1 and worker 260

Where am I going wrong?

Please help sort it out

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Cosmic Heart Beat!

    We answer the questions in the order they come in, so sometimes bumping a thread can have a negative effect on your spot in line. : )

    You’re correct, I can’t test your appointments settings if I’m not logged in. Would you mind allowing me a look under the hood?

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks!

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Sorry I am new here…

    I noticed that when I post something I get a response fairly quickly which is usually a lot of question but thin on answers. I respond to those asap but then all support disappears…It felt like I was forgotten, so I posted it again

    same thing happened again…

    I gave access to the site this morning but no one came by to help I revoked it just before you came back.

    I am afraid In my time-line waiting over 24 hr for more questions is far too long a wait.

    The shortcodes do not work as advertised!

    Unless one adds the following [app_services worker=”id”] on the page,

    there is always the same calendar displaying = service 1

    Reluctantly I added this shortcode on each provider’s page with their respective worker Id and that resolved it.

    I assume this is a bug along with those

    [app_worker_monthly_calendar]

    or

    [app_worker_monthly_calendar worker_id=”260″]

    displaying empty boxes…

  • Tyler Postle
    • CGO

    Hey Cosmicheartbeat,

    Hope you’re doing well today and thanks for your question.

    It looks like the access has either expired or been revoked, so I instead tested your exact setup(from what I can tell) on my own installation and it worked exactly as expected, the appointments both booked under the correct providers.

    I have attached my screenshots of service providers and services so you can double check your own setup and I’ll copy and paste the shortcode used as well; however, I just copy and pasted yours then changed the ID’s.

    Service 1:

    [app_my_appointments]
    [app_monthly_schedule service="1" worker="1"]
    [app_pagination month="1"]
    [app_confirmation]
    [app_login]

    Service 2:

    [app_my_appointments]
    [app_monthly_schedule service="2" worker="3"]
    [app_pagination month="1"]
    [app_confirmation]
    [app_login]

    *Note: Another option, since your services only have 1 worker each, you can just put the service ID and you don’t need the ‘worker’ parameter at all, it will default to the only worker for that service.

    If you’re still having the same issue then you will need to grant access again so I can take a closer look at your setup and see exactly what is happening :slight_smile:

    Look forward to hearing back from you Cosmic!

    All the best,

    Tyler

  • Tyler Postle
    • CGO

    Hey Cosmic,

    As I was closing your other thread I noticed a secondary question in it that I did not address here:

    [app_services select="any other text"] makes no difference at all – the default text still appears.

    I just copy and pasted that exact shortcode into my test environment and it worked as expected. Have you checked for plugin conflicts? You could have plugins installed that are conflicting with the shortcodes – try deactivating all plugins except appointments+ then seeing if the text changes as expected.

    If that doesn't work then temporarily switch to the default 2014 theme – that will ensure there isn't a theme conflict either :slight_smile:

    Look forward to hearing back.

    All the best,

    Tyler

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Hi Tyler

    Thank you!

    I followed your advice and removed the worker id

    copied your code (which looks identical to my initial code)

    And pasted it to test pages

    ALL WORKS PERFECTLY

    I changed nothing in my computer set up: Same browser session (did not empty cash)

    I changed nothing on the site setup

    Got read of [app_services worker=”id”] on the pages I did before + your pasted code – And all is well

    —-

    I suspect it is a cashing issue

    Despite having it set it up to advance -use built in cash > NO is selected and never was set to yes.

    I do not have any other cashing plugin on that site either

    Here is what leads me to this conclusion:

    If you recall I was asking you on another ticket about providers access to their own appointments in the settings. What I then done as a temporary measure is; went into the appointments setting page created a filter and used the link to the filtered page to give access to each provider to their own appointments. I put this link ‘Admin’ at the bottom of their respective appointment page.

    What happened on the page looked like this

    I had a link Admin and An extra word appearing not as a link Admin

    It seemed link it attached it to the following short code

    [app_services]

    Once I got read of that on the pages the word Admin was gone too leaving only the link on the page.

    Today while testing your suggestions I created a new page

    Pasted ONLY the line [app_services select=”any other text”] and guess what happened – The word Admin appeared on the page!

    My logic is tell me this could only be a cashing issue

    Any other ideas or explanations would be welcomed.

  • Tyler Postle
    • CGO

    Hey Cosmic,

    Glad we got the first part working! Good stuff.

    That ‘admin’ issue seems quite odd, do you have the service connected to a description page at all?

    You can see this in your services tab and on the far right there will be a description page selection. It will take the excerpt from that page by default.

    If that isn’t it then if you could grant support access I can take a closer look and investigate where the ‘admin’ is coming from.

    Look forward to hearing back Cosmic :slight_smile:

    Cheers,

    Tyler

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    I am now having another issue

    I just got the hours from one of the providers

    And it is not regular at all

    So I am not too sure how to set it up

    I Understand the exception and holiday setting

    But it is how to set the hours that are different on different dates not on different days

  • Tyler Postle
    • CGO

    Hey Cosmic,

    Do you mind granting support access so I can take a closer look at the ‘admin’ issue? Or linking to a page with issue on it so I can take a look at the code, that could reveal where it’s coming from :slight_smile:

    So I am not too sure how to set it up

    I Understand the exception and holiday setting

    But it is how to set the hours that are different on different dates not on different days

    Making a dummy provider is the best solution for this, then you can set different hours for it and set all days “OFF” then list the few days that you need different hours in the exceptions. Or the other way around if you need several days that are different hours.

    Marking it as a dummy provider just means that the emails will go to the user you have assigned to dummy providers in the general settings. It was created so you can set different hours if needed :slight_smile:

    Hope that helps Cosmic!

    Let us know if you have any further questions.

    Cheers,

    Tyler

  • Titanium Creative
    • Finder of Elusive Bugs

    Tyler, quick sidebar here. I notice you are defining the shortcode app_services. Wouldn’t that have a high likelihood of conflict? As opposed to something like wpmu_app_services?

    I have been prefacing my short codes with ticr_ for that reason. Is it not necessary?

    Thanks and my apologies for the sidebar.

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Hi Tyler

    1. You have access

    2. Set up provider gemma hours

    I set the hours as they should be on her working hours and selected all working days Off

    then added the working days in the exceptions

    All appear OK

    However the working hours of the no specific provider were set to the defalt 8:00-5:00, But gemma works until 8:00pm

    The calendar was showing only possible appointments up to 5:00

    So I changes the no specific provider hours to 10:00PM just in case that is what effecting the limit but it made no difference

    again I suspect it is a caching issue

    I test it with few browsers that had no history of the pages

    And same problem persist

  • Tyler Postle
    • CGO

    Hey Cosmic,

    Thanks for the screenshots there! That helps. I’ve been testing this out on my end and seem to be getting the same behaviour, before I go ahead and mark this as a bug I just want to know what your installation is doing when you have both providers on the same page with the “no specific provider” so temporarily apply both services to each provider.

    and make a page with this shortcode:

    [app_my_appointments]
    [app_services]
    [app_service_providers]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_login]
    [app_confirmation]
    [app_paypal]

    When you have it at no specific provider is it still not showing availability between 6-8 when you have it on october 8th? Assuming that’s one of your “exception” days.

    A possible alternative for the time being would be to do it the other way around where you set working days to Yes then set non-working days.

    Look forward to hearing back Cosmic, I’ll pass our findings onto the developer so we can get this resolved :slight_smile:

    Cheers,

    Tyler

    Wouldn’t that have a high likelihood of conflict? As opposed to something like wpmu_app_services?

    @Titanium Creative In my time as a member and now as staff, I still haven’t seen anyone make a thread about another plugins shortcode conflicting.

    You do make a good point though, thanks for bringing it up :slight_smile: our most recent plugins use shortcodes with more unique names. So seems like the devs might have felt the same way.

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Hi Tyler

    I set out to test the dummy thing you suggested so I set up myself withone user as a provider dummy and my admin user as the dummy email thing

    Then had a client call so had to stop what I was doing till now

    coming back to this have seen your next post

    I am not sure about setting it for no specific provider

    But I just created a test page to follow your request before setting up the no specific thing

    so have a look a this the test dummy user

    I have the full time appearing

    the test page has your code as above

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Gemma is set to work on Mondays till 8:00 pm

    So It is possible that the what creates it is the ‘works? NO’ setting.

    Or like I said there is some issue of cashing within the plugin –

    because of all the other anomalies I am experiencing I wonder….

    If this resolves by itself tomorrow we will know for sure it is a cashing issue!

    The thing with Gemma schedule is that she works few days and setting it the other way is just a lot more work. At this point I am doing it for her but I need her to be able to do it herself and right now I can not pass it on to her if I am not confident it works perfectly.

    P.s. I also tried to use the – Clear Cache tick box no change of course…

  • Tyler Postle
    • CGO

    Hey Cosmic,

    Thanks for all your patience here. I have done some further testing with the exceptions and this is definitely a bug by the looks of it. As soon as you turn that day to YES for working then it will show as it should, but when it's set as "NO" then even if you have set the exception for it, it doesn't seem to give the same behaviour as if it was set to YES.

    In fact, mine seems to just always stop at 6pm, like yours. I'm attaching some screenshots just to illustrate my behaviour so you can see it and double check yours is the same, sounds like it is.

    Here's what I did:

    1. Set all working hours to NO

    2. Set a specific wednesday for exception and set working hours 4pm-8pm

    3. Went to calendar and those times went from 4pm-6pm (should be 8pm)

    4. Set working hours to YES

    5. Times should have 4pm-8pm exactly as they should

    It's missing out on 2 hours with the exception. This information is also to help the developer as well :slight_smile:

    So I believe you were right here Cosmic, it is the 'NO' setting that seems to part of the issue. I believe it should be showing correctly with the exception though.

    This shouldn't be a caching issue, so no worries on that front.

    I am notifying the developer now. In the meantime, let us know if you have any further questions!

    All the best,

    Tyler

  • Tyler Postle
    • CGO

    Hey Cosmic,

    Thanks for your reply!

    Yes, nothing related to that has been changed in the most recent version.

    How long before this will be fixed?

    I’m not 100% sure what will be involved in fixing it, so I can’t say for sure; however, we mark bugs as top priority. They get pushed above everything else. So, we usually get them fixed up pretty quickly :slight_smile:

    As soon as it’s resolved I’ll post here to let you know! Or the developer will.

    In the meantime, let me know if you have any further questions.

    Have a great day Cosmic!

    Cheers,

    Tyler

  • CosmicHeartBeat
    • Design Lord, Child of Thor

    Hi Tyler

    1. Thanks for all your help and patience – Yes it will be good to know when this is fixed so please post here when it is done.

    As I said I have plans for that plugins so it is highly important for me to know when this is fixed.

    2. I now need to set up the other provider and her hours are even more unregulated so would really appreciate some more explanation on the dummy provider and how to use it to get what I need.

  • Tyler Postle
    • CGO

    Hey Cosmic,

    1. Thanks for all your help and patience – Yes it will be good to know when this is fixed so please post here when it is done.

    We’ll let you know :slight_smile:

    2. I now need to set up the other provider and her hours are even more unregulated so would really appreciate some more explanation on the dummy provider and how to use it to get what I need.

    Basically you can think of a dummy provider as just another set of hours for your main provider or whoever you want to assign dummy providers too.

    All service emails sent to the dummy user will actually get redirected to whoever is assigned to them. So, as I just mentioned – it really is just a second instance of the same provider that allows you to set different hours.

    This part of our video tutorial explains it further, I’m linking you to about 2:30 into this video where we start discussing dummy providers: http://youtu.be/yjOqzODIO7c?t=2m32s

    Hope that helps make it more clear Cosmic!

    Let me know if you have any further questions on any of that.

    Cheers,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.