Shortcode display depending on role


Hope you are doing Good ,

I don’t wanna to display ” [jbp-job-post-btn] , [jbp-job-browse-btn]” this for student role .

  • Majid
    • Recruit

    Hello darshan ,

    I hope you are doing great today :slight_smile:

    Please try adding the following code to your theme’s functions.php file. this should remove the content of both shortcodes from users with Student role

    function filter_jbp_shortocodes( $output, $tag ) {
    if( $tag == 'jbp-job-post-btn' || $tag == 'jbp-job-browse-btn' ) {
    global $current_user;
    $roles = $current_user->roles;
    if( ! empty( $roles ) && is_array( $roles ) && in_array( 'student', $roles ) ) {
    return '';
    return $output;
    add_filter('do_shortcode_tag', 'filter_jbp_shortocodes', 10, 2);



  • darshan
    • Site Builder, Child of Zeus

    Hi Majid ,

    Thank you for the code it worked .

    I wanna to change th text "You don't have any job" . I found out the file where the text is coming from path is


    I edited the text accordingly in the file but I could not see the updated text in front end .

    one more issue in events plugin , after creating event .. I could not see map for the location given . Updated Version of Google Maps plugin is activated .

    Attached screenshots for better understanding .

  • Majid
    • Recruit

    Hi darshan

    The file you have found is actually a translation file and not the file used to display the front end text, the file containing that is under /plugins/jobs-plus/app/views/my-job/main.php

    And as a side note, the edits made to the core files will be removed once the new plugin update is installed, so it's not very recommended.

    Regarding Events+ issue, I noticed that you didn't set your Google Maps API key yet, which is important for the map to display.

    Settings > Google Maps > Options tab and follow the link



  • darshan
    • Site Builder, Child of Zeus

    Hi Majid ,

    Some documents published by admin are visible to students and some are not …

    I created one document from student role , it is visible to admin and student .

    I created three documents from admin role (all docs are having same settings) , only one is visible to student what might be the issue ??

  • Nastia
    • Support Rock Star

    Hello darshan

    Hope you are doing well!

    Would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:

    Please let us know how you created these documents and where we can look for them on your site? Are these are uploaded from the Media > Add New menu?

    Please advise,

    Kind regards,


  • darshan
    • Site Builder, Child of Zeus

    Hi Nastia ,

    I am doing good and hope the same from you .

    I granted support access for ” ” site .

    In the frontend , on buddypanel menu ” Concepts ” you can see the documents .

    Documents are created from frontend , not from media . The issue we are facing is all the documents created by admin are not visible to student . For admin all the documents are visible.

    Please login with student credentials for better understanding .

    username : iisgl_student

    password : student

  • Dimitris
    • Support Star

    Hello darshan,

    hope you’re doing good today and don’t mind me chim in here! :slight_smile:

    I tried to access your website but I got the following message:

    This access token has expired. Please ask the user to renew it.

    Could you please go to WPMUDEV -> Support in the wp-admin area, revoke support access and re-grant it?

    Let us know here in your next reply that you did so, as we don’t get any notifications about it.

    More info on granting us support access can be found here:

    Warm regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.