shortcode show wrong information?

Good morning, I would consult the following.
I created 3 locations. Needing assign the same services at 3 locations, I created all services triplicate (one for each location) then I created the service providers.
When the page displays this shortcode "[app_service_locations]", all locations are repeated 3 times, it's like show services but with the name of the locations.
There are some problems with this? why showing repeated locations?
My idea is to choose the location first, then the service at that location and then the service provider.
How can I configure it to work well?
Thank you very much.
Regards

  • Tyler Postle

    Hey Gustavo,

    I was testing this out on my own installation and I believe I found a better solution for you, it is a bit of a workaround but it works well :slight_smile:

    I'm going to start from the beginning even though you likely already have locations setup so you can probably skip first couple steps. Here is what you do:

    1. Activate locations add-on

    2. Activate "Workers Location" add-on

    3. Setup your 3 locations in the locations tab

    4. Set up 3 different service providers (2 of them will be "dummy" providers)

    5. Apply 1 location to each provider and all 3 services to each provider

    6. Setup your 3 services

    7. Use "[app_required_provider_locations autorefresh="1"]" shortcode first then use the service one "[app_services]" on your appointment page.

    Essentially, we are just linking the location to the provider instead of the service. Since we only have 1 provider we had to create 2 dummy providers, once you link the dummy providers to the main provider on the Appointments > General settings tab then all emails will go to just the one provider.

    You can make the dummy providers display names pretty much the same as the main provider - this way users won't know any difference but it allows you to have 3 locations.

    Hopefully this makes sense! I'm afraid I may have made it seem more confusing then it is :p let me know if you need any assistance setting this up!

    All the best,
    Tyler

  • Gustavo

    Good evening, I finally set as you told me.
    First I set all 3 locations, services then 4, then all service providers linked to locations.
    On page wrote the following shortcodes:

    [app_provider_locations autorefresh = "1"]
    [app_services autorefresh = "1"]
    [app_service_providers autorefresh = "1"]

    The problem with [app_provider_locations autorefresh = "1"] is that locations are repeated.
    Eg.
    Location 1 working three service providers
    Location 2 working two service providers
    Location 3 1 service providers working

    The dorp box displays:
    Location 1
    location 2
    location 3
    Location 1
    location 2
    Location 1

    I would like to know how I can do to choose locations, services and service providers in separate drop box and autorefresh?

    something like this:

    [locations autorefresh = "1"]
    [services autorefresh = "1"]
    [service_providers autorefresh = "1"]

    I hope you can help me, thank you very much for the answers.

  • Jose

    Hey there @Gustavo,

    Hope you are doing great :slight_smile:

    I've made a fix before for the duplicated locations in the dropdown. I think the same fix will work perfect for you, and you can use the settings as you were using at the beginning:

    You will find attached a .zip file containing two .php files:
    - app_service_locations_shortcode.php
    - app_worker_locations_shortcode.php

    You only need to replace those files under the following location:

    ..\wp-content\plugins\appointments\includes\addons\lib\

    This will fix the duplicated location for both service associated locations and worker associated locations.

    Please let me know if it works fine now. I'll be available to make any necessary adjustment. :slight_smile:

    Cheers!,
    Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.