shortcodes for registration form

Hi

I have a number of membership products - i would like to create separate registration pages for each product.

I have taken the shortcode and added it to a page. The problem is when i add the shortcode to the page an issue appears where the page doesn't even display, i get a white screen.

I was previously using the membership plugin and have upgraded this.

Not sure why the registration form will not show up it is very strange and getting increasingly frustrating.

Please help!

Thanks

  • Justin
    • Site Builder, Child of Zeus

    Hi Michael

    Thanks for your reply.

    I have enabled support access now.

    The membership in question is actually all of the membership products, none of the shortcodes seem to work.
    I would like to build my own user journey by simply adding the registration form to relevant pages.

    I have added a registration form shortcode to the following pages but nothing actually shows up:
    /register
    and
    /how-it-works (on this page the form shortcode has been added towards the bottom of each tab below the register button - i want to replace the register button with the registration form)

    Many thanks again

    Justin

  • Michael Bissett
    • Recruit

    Hey @Justin,

    No problem, thanks for enabling the Support Access to your site! :slight_smile:

    In looking at this further, the page is actually loading, but the thing is that your theme uses a transition effect when the page gets loaded, the content of the whole page has an opacity of 0 initially, which then gets adjusted to 1 (100%).

    It does this via a script, which is enabled by setting "Page Loading" to "On" inside of:

    Appearance -> Theme Options -> General Settings

    The thing is, there was a jQuery error coming up on the page (coming from Membership 2 Pro), which caused that transition effect to abort, hence the white page.

    I've just applied a patch to your site for this (which will be including in an update), and am now seeing that the pages you mentioned are working properly, can you confirm this on your end as well? :slight_smile:

    Please advise,
    Michael

  • Justin
    • Site Builder, Child of Zeus

    Hi Michael

    Apologies, I have only just realised that when i complete the form nothing happens.

    On submitting the details the page/form simply refreshes and the user is not directed anywhere. The new user appears under 'users' but there is no trace of them under 'all members' in the membership 2 plugin.

    I would expect when the user registers they are redirected to a membership page and be given the correct permissions for the membership registration form?

    Could you take another look please at the same pages?

    Thanks

    Justin

  • Michael Bissett
    • Recruit

    Hey @Justin, thanks for doing that! :slight_smile:

    (and I meant to say, hope you had a great weekend, not having... coffee exists for a reason!)

    Anyhow, had a look through things here, and I'm finding that the registration forms on both of these pages:

    /register
    /how-it-works

    Are working just fine for me, I get assigned the subscription, and am taken to the "Registration Complete" page.

    Before doing this, I did refresh the permalink structure by going to:

    Settings -> Permalinks

    And saving the settings there.

    Can you confirm that the forms on those two pages are working properly for you now? :slight_smile:

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.