Shortcodes not working in membership

Shortcodes don’t appear to be working, and neither does content protection. For example:

I have 2 access levels, free and paid.

I create a page, called videos

On this page I created some text, then put in [level-paid] more text here then [/level-paid]. My free user can see that text, plus the “[level-paid]” text.

Secondly:

I went opened Level paid and added the video page to the Positive rule. I went into level free and added the video page as a negative rule. Free user can access the page.

I feel like I am completely missing something simple here. Yes, Membership Protection is Enabled :slight_smile:.

  • PC
    • WPMU DEV Initiate

    Hello again Ed :slight_smile:

    Thanks for your post.

    It seems to be an issue with the setup. Did you checkout our user manual to do it step by step ?

    https://premium.wpmudev.org/wp-content/uploads/2010/05/Membership-Documentation-SJC.pdf

    Also go to Membership >> Content Protection >> Scroll down to the bottom and click on save changes. And it will show the available shortcodes on the top of the page after it.

    Please advise.

    Cheers, PC

  • ed_farias
    • Design Lord, Child of Thor

    I thought I followed the step by step guide :slight_smile:.

    I did what you suggested, clicked save changes on the Content Protection page. No where on that page do I see the available short codes.

    I had another post about removing membership complete and reinstalling, I did see the answer to that. I have tried deleting the plugin a few times, but this issue seems to persist.

    Thanks.

  • PC
    • WPMU DEV Initiate

    Hiya @ed_farias

    Thanks for posting back.

    It seems an issue with the setup to me.

    Reinstalling will not simply help here. I will need to have a closer look at the settings to see what might be wrong.

    Can you please send me your admin login details via our secure contact form and mark it to my attention and also include a link to this thread ?

    Please use “I have a different question” while submitting the contact form.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hiya,

    This is how I tested it.

    I added the below to the video page

    Blah Blah Blah (Available to all)

    [level-platformer]

    Blah Blah only visible to level Platformer

    [/level-platformer]

    [level-free-videos]

    Blah Blah only visible to level free videos level

    [/level-free-videos]

    [level-all-videos]

    Blah Blah only visible to level All videos level

    [/level-all-videos]

    Then I visited the page as a normal user (visitor level)

    And here is what I see

    Then I created 3 users

    allvideo

    freevideo and platformer and assigned them to respective access levels

    and I logged in using those accounts one by one.

    And this is what I see

    allvideo

    freevideo (because that is added to negative rules in freevideo access level, that member cant access that page)

    platformer

    So, its all working fine according to me.

    You should be using different browser to test it out while you are working on the site and the best way to do it is, create a new user, assign that to an access level manuall and check things out :slight_smile:

    I hope that helps.Please feel free to ask if you have more questions.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    You are most certainly welcome Ed :slight_smile:

    That must have been it, even though I was assigned free video only access, I’m an admin so naturally I would see everything.

    That happens quite often. We are logged in as admin and the rules dont work :stuck_out_tongue: lol

    Please feel free to ask if you have more questions on the same and I will be around.

    Marking this resolved. I hope you found us helpful :slight_smile:

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.