Shortcodes Ultimate issue in Multisite

Hello all,

I am having a very strange behavior with a SU shortcode on sites in Multisite that I did not have on stand alone sites.

First - I have changed themes and it is not a theme issue.
Second - no I have not turned off all plugins and I am not going to. The last time I turned off all plugins, I had to spend hours turning multiple items back on and reconnecting sites.
Third - Yes, I cleared both site cache and browser cache after each change.
Fourth - I tried this on a clean test site in the same multisite network with the same result.

Here is what is going on:
1. I create a new page, add content, do not allow commenting, save.
2. Go back to page list, reopen page to edit, no problems.
3. I add the SU shortcode [posts .....] to the page to display recent posts, and save.
**** The page displays fine on the front end
**** This is where things go wrong
4. The page refreshes after saving and now the comments box is checked.
5. I go back out to the page list and the the page is showing in the list.
6. I go back into the page and now the page's permalink has been changed to the link of the first post on the list. And now the original page comes up as a 404 error - Page is Gone.
7. The permalink to the first post now displays the page with the shortcode and the post.
****
When I remove the shortcode from the page, I can now uncheck the comment box however, the permalink does not change back.

The only way to correct this is to permanently delete the original page and make a new one.

Has anyone run into a same/similar situation/condition with this or another plugin?

Let me know if you need any other information that may be helpful.

Thanks,
Bill .. .. .