Showcase theme distorts photos in posts

This is in reference to the showcase theme, WP single user 3.0.5, CentOS server 5.5, latest everything.

Site can be seen here: www (dot) adventure-panama (dot) com

First, let's be blatantly clear on something - if theme is set to WP Twenty Ten, there is no issue. The issue only arises when theme is set to Showcase - a theme purportedly designed for images. Also, I am fully cognisant of aspect ratios, and how to maintain them correctly - I've been taking, processing & working with images for 20 years.

Post where issue is seen - Panama Canal Tours - notice how all the images have that lovely vertical stretch to them? Everything is tall and thin - great if you are photographing short, fat people. Anything else, not so much.

The original images are 1000x667. Since Showcase is a very vide 1 column theme, I decided to upload the images (using the WP internal media handler / gallery - NextGen is NOT installed) with the radio button "original" checked.

The uploaded images look great, and appear undistorted if you click on them to view in single image mode. But when the images are displayed in the post, they are scaled to 640x667 - which unto itself is not a terrible thing. BUT, when the scaling is NON-proportional, it is completely inexcusable for an image / gallery oriented theme.

Please either:

1) Fix you code to display image in their original aspect ratio.

2) Or, alternatively, indicate the correct method to insert images into this theme without it distorting the images with it's own non-proportional scaling.

If it's 2, then you should have configuration notes indicating the limitations of the theme. For a premium paid theme such as this, it's completely unacceptable to have to second guess the designer on how to operate the theme for maximum efficiency and results.

  • Philip John

    Hi Bobohobo!

    I can see the distortion that you mention on that post.

    As the images are so large they have triggered a "max-width" setting in the theme to prevent them becoming too wide.

    Good news however: removing this is easy!

    You simply need to open up the style.css file using a text editor, find line 905 where you will see this;
    max-width: 640px;

    Simply delete that and the restriction will be gone!

    Phil

  • Tammie

    The change is a simple CSS one you can do as you want as wide images as possible no sidebar you in the child theme or CSS just add in this:

    #content img {
    margin: 0;
    max-width: 960px;
    /* or no width.. up to you if want to limit */
    }

    There is a maximum width set to optimise images to not full width but you can easily work around that by doing this. We try and cater for the majority of cases and for everything else we offer like we're doing here options with CSS.

    We'd recommend firebug if you want to do design customisation as can help identify what is a theme option, CSS or something intended.

    EDIT: That's me and Phil posting at the same time :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.