sidebar, image & drop down menu

Hello,
I am having a few problems in setting up the Classifieds plugin on my test site.

1. On the Classifieds page, there are two images showing when I have only entered one image as a Feature Image. How do I removed the top one that is sitting above the ad?

2. I can't find where or how to change the sidebar. On each of the three Classifieds pages, I have set the custom sidebar to one I had prepared earlier to test things out but the sidebar that has shown up seems to be a default one and I can find that anywhere or how to change it. The Classifieds Checkout page is the only one that seems to be using the correct sidebar but page settings are the same as the other two pages, so I have no idea why this is happening.

Can you please help me out with these things?

Regards, Tamara

  • Ash

    Hello @Tamara

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Showing two images is mainly an issue from your theme. Would you please grant support access from your Dashboard > WPMU DEV > Support > Support Access so that I can check both issue?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

  • Vinod Dalvi

    Hi Tamara,

    Thank you for granting the support staff access.

    1. On the Classifieds page, there are two images showing when I have only entered one image as a Feature Image. How do I removed the top one that is sitting above the ad?

    I could confirm the issue on your site but couldn't reproduce it on my test site using latest version of Classifieds plugin and default Twenty Fifteen theme.

    I think it's Enfold theme specific issue that you are using on your site.

    You can just hide the top image by adding the following CSS code in the style.css file of your child theme or add it in your site using the following plugin.

    https://wordpress.org/plugins/simple-custom-css/

    body.single-classifieds .entry-content-header .page-thumb {
    display: none;
    }

    2. I can't find where or how to change the sidebar. On each of the three Classifieds pages, I have set the custom sidebar to one I had prepared earlier to test things out but the sidebar that has shown up seems to be a default one and I can find that anywhere or how to change it. The Classifieds Checkout page is the only one that seems to be using the correct sidebar but page settings are the same as the other two pages, so I have no idea why this is happening.

    How have you set the custom sidebar?

    Could you please share me the page URLs of three Classifieds pages that you are referring here?

    Please tell me a bit more in detail what you are trying to achieve so that we can help you to achieve it.

    You can also use our following Custom Sidebars Pro plugin to use custom sidebar on any page/post.

    https://premium.wpmudev.org/project/custom-sidebars-pro/#usage

    Regards,
    Vinod Dalvi

  • Tamara

    Hi Vinod,
    Thank you for your response.

    I have added that code into the custom css within my Enfold theme. Unfortunately, it has not fixed anything. Do you have any other suggestions?

    With regard to the sidebars... I have set up custom sidebars in the theme Widgets area. I have used those on all other pages in the site.
    The three classifieds pages I ham referring to are those generated by the Classifieds plugin:
    http://aquamarine.genkidesign.com.au/classifieds/
    http://aquamarine.genkidesign.com.au/classifieds/my-classifieds/
    http://aquamarine.genkidesign.com.au/classifieds/checkout/
    Within each of these pages, I have set the sidebar to be my custom sidebar. It works on the last link but not either of the others. The set up is the same on each of those three pages to use the same custom sidebar but that is not what is showing. The sidebar that is showing on the first two pages seems to be generated by the Classifieds plugin but I don't know where or how to change that.

    Thanks, Tamara

  • Ash

    Hello @Tamara

    I hope you are well today.

    I thought you were using our Custom Sidebar plugin, but I can see you are using sidebar option from Enfold theme. So, I can't confirm if it will really work with classifieds.

    I can try to force to replace the sidebar by some custom code, but again, I can't confirm.

    Would you please send me admin login details and FTP details?

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Ash (this ensures that it will be assigned to me)
    Details:
    1. Send all requested details
    2. Send a link of this thread so that I can track
    3. Send any other relevant link

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

  • Tamara

    Hello,
    No, I am not using the Custom Sidebars - I feel that this should be something that works without spending that additional money for another plugin.

    I can send you those login/FTP details but, before I do that, is there any way of accessing and changing the sidebar that is automatically generated on those pages?

    Also, is there any solution for the additional image that is being placed at the top of the Classifieds page?

    Thank you, Tamara

  • Tamara

    Hello again,
    I have worked out where I can edit the default sidebar and am in the process of making that look ok. The default Classifieds Checkout page sidebar is still a little different and I'm not sure why but it is working a lot better than it previously was.

    If you are able to let me know how to fix the issue with the extra image at the top of the Classifieds page, that would be great.

    Thank you, Tamara

  • Ash

    Hello @Tamara

    I hope you are well today.

    If you are able to let me know how to fix the issue with the extra image at the top of the Classifieds page, that would be great.

    Please try the following css:

    body.post-type-archive-classifieds div.page-thumb{
    display: none !important;
    }

    You can add this to a theme's stylesheet, in a child theme, or using a plugin like My Custom CSS.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Tamara

    Thanks so much. I added that code to my theme custom css and it worked on the Classifieds page.

    But, when you click on one of the text classified ads I have on that page and you are taken to a page with the one advert, the extra image appears again.

    I wanted to try and test how the images work by placing an ad on the site when I wasn't logged in (these have been placed through the WP backend which users won't do) but I haven't been abel to successfully sign up as a new user.

    Can you please also help me there? When I go to the sign in page and set up a new user/password it doesn't seem to work. I get redirected to the WP login page which doesn't seem correct. I suspect there is something basic that I am doing wrong but just can't figure it out. Can you please help?

    Is there any documentation for this plugin to show how every step of the process works?

    Thanks again, Tamara

  • Vinod Dalvi

    Hi Tamara

    I have got that "Anyone can register" box checked but, when you try to enter new sign up details, the page still directs to a Wordpress login page.

    I have just tested registering on your site both from default WordPress registration form and using Classifieds registration form and it worked fine for me without any issue.

    I have attached screenshots of Classifieds registration and login forms that i have used to test it.

    Please advise where and how you are facing the issue?

    Regards,
    Vinod Dalvi

  • Tamara

    Thanks so much for your help Vinod!

    This seems to be working a bit better for me now. I was able to go to that 'New Account' section and register for the site.

    The only problem I have now is that after I have put a new username and email address in there, the page automatically directs back to the home page of the site. There is nothing that tells the user to wait for an email with a password. This would be very confusing to someone who doesn't know what to expect.

    I knew to wait for the password so I did that and then logged in with the password I was sent. But when I used that, the site redirects again to the home page without telling me my login was successful.

    Does that all sound correct to you? Is there a way of giving people that important information?

    Also, are people only allowed to use a generated password rather than one they select?

    Thanks again, Tamara

  • Vinod Dalvi

    Hi Tamara,

    On registering using classifieds registration page the appropriate message is displayed on my site as shown in the attached screenshot.

    I am not sure why it's not working on your site but i think this can be due to plugin/theme conflict on your site.

    You can just try on your development site using default WordPress theme like Twenty Fifteen and temporary deactivating all other plugins as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    The classifieds signin URL should be as following so that users can see that they are logged in.

    http://yoursite.com/classifieds/signin/?redirect_to=http://yoursite.com/classifieds/signin/

    To achieve this try using the following custom code in the functions.php file of your child theme or try using the attached small plugin.

    function my_page_template_redirect()
    {
        if( is_page( 'signin' ) && ! is_user_logged_in() && !isset($_GET['redirect_to']) )
        {
            wp_redirect( get_permalink().'?redirect_to='.get_permalink() );
            exit();
        }
    }
    add_action( 'template_redirect', 'my_page_template_redirect' );

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.