Sidebar Login Hangs

I've installed Forums and Wiki on a site using the Builder Acute theme. I've tried a number of options to get user accounts implemented: Membership, Symposium, BuddyPress, Mingle Forum. To get a user login capability, I've tried Sidebar Login and Theme My Login as well as providing a simple link to the wp-login page. None of them worked. In the course of all this something got messed up on my site and I've been unable to repair the problem. As a consequence, I gave up on Membership and the notion of trying to protect my Support pages, and decided just to go for a simple user login to provide access on registration to users. Now, when I try using Sidebar Login on the following page, it hangs with a spinning beachball (you can see this by putting any values in the Username and Password fields):

http://high-tech-coach.com/your-account-2/

I've tried installing Builder Acute, Sidebar Login, Forums and Wiki on my sandbox, and the Sidebar Login works fine (if you put some junk in the username and password fields you'll get an error message):

http://www.metier-coaching.com/sandbox/

I feel like I've exhausted my possibilities, and I don't know what else to try. I've put a lot of work into the site as it is, and really don't relish the thought of recreating the whole thing from scratch.

  • Kimberly

    vingogly,

    Welcome to WPMU forums!

    You sound like you are having quite a time!

    Let's see how we can get you sorted. First: Membership handles the registration in wordpress when it's installed. It is used via a [subscription form] shortcode.

    You may be having an issue with your login plugins conflicting. I'm not familiar with your sidebar plugin, but I am thinking if you have two plugins trying to take priority for a single function that will get nowhere.

    You reference you've tried many options but

    None of them worked

    Did they not work the way you expected or did they not function correctly.

    Plugins are great but they can often cause problems. They are not all created equal and many just don't play nice. :slight_smile:

    What are you currently running for plugins?

    Here is a quick way to test how well they are working together: turn off all but the problematic plugins. Then re-test. If it works then turn on the others one by one until you find the oddball.

    In the course of all this something got messed up on my site and I've been unable to repair the problem.

    Are you referring to the login issue or are there other things going awry?

    Best,

    Kimberly

  • vingogly

    All plugins are deactivated except for the following:

    Forums
    Sidebar Login
    Wiki
    WPMU Dev Update Notifications

    That's it. Same configuration as on my sandbox, and the Sidebar Login hangs on the live site, but not on the sandbox. I believe I checked the error log in Safari at one point and noticed a XMLHttpRequest error, which says to me AJAX is failing to connect to the server.

    When I say none of them worked, I mean none of these membership solutions functioned correctly. When I say "something got messed up", I'm referring to the inability to login. My site is located on the Bluehost server at: http://www.metier-coaching.com/hightechcoach, but the domain is high-tech-coach.com. So one suspect is some problem with the way paths are getting resolved.

    I've also gone into phpMyAdmin and deleted the crud tables left over from my membership plugin experiments, but that hasn't fixed the login problem either. When I had Membership installed, I tried getting it to work with Theme My Login since that's mentioned somewhere on the Membership page, but when I tried it then tried to access the Forum or Wiki pages, there was no login established (which suggested a cookie problem, perhaps).

    There's a table in the database named login_redirects; I don't know where that came from but I don't believe it's part of the standard WP install. I'm thinking it was created by one of the login or membership plugins I've tried, and wonder if it might be the source of the problem. I might backup the DB and delete the table to see what happens.

  • vingogly

    The above doesn't work. I've place the Meta widget in the sidebar, and when I login with either my admin login or the editor login I created for testing, it appears I'm not getting logged in. Meta still shows the login link (rather than logout) and no posts can be created or changed in the forums.

    I'm starting to think one of the plugins I tried along the way messed up WordPress's cookies (prime contenders: BuddyPress and Symposium). I changed all the keys in wp-config.php, that didn't help either.

  • vingogly

    I looked at the error log on the server, and I see these errors cropping up repeatedly:

    [03-Mar-2012 20:53:09] WordPress database error Table 'metierco_wrd5.3f26_blogs' doesn't exist for query SELECT path FROM 3f26_blogs WHERE blog_id = '' made by require, require_once, include, do_action, call_user_func_array, BuilderLayoutSelector->render, do_action, call_user_func_array, BuilderLayoutEngine->render, do_action, call_user_func_array, BuilderLayoutEngine->render_container, do_action, call_user_func_array, BuilderLayoutEngine->render_container_contents, do_action, call_user_func_array, BuilderLayoutEngine->render_modules, do_action, call_user_func_array, BuilderLayoutEngine->render_module, do_action, call_user_func_array, LayoutModule->render, do_action, call_user_func_array, BuilderLayoutEngine->render_module_contents, do_action, call_user_func_array, LayoutModule->render_contents, do_action, call_user_func_array, BuilderLayoutEngine->render_module_element_block, do_action, call_user_func_array, LayoutModule->render_element_block, do_action, call_user_func_array, BuilderLayoutSelector->render_module_element_block_contents, do_action, call_user_func_array, LayoutModuleContent->_render, do_action, call_user_func_array, render_content, the_content, apply_filters, call_user_func_array, SlidingNotes_FrontendPostFilters->the_content, SlidingNotes_FrontendPostFilters->appendBodiesTo, SlidingNote->bodies, SlidingNote->body, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, forum_shortcode, forums_output, forums_output_view_topic

    and

    [03-Mar-2012 20:59:24] PHP Warning: Invalid argument supplied for foreach() in /home5/metierco/public_html/hightechcoach/wp-content/plugins/wiki/wiki-include.php on line 200

    Not sure about the second one related to the Wiki, bu the first one seems to suggest there's something related to WPMU hanging around on my site ... maybe as a result of having installed BuddyPress or Symposium. I do see a "sites" folder on the server, which I believe is MU related. I don't really need an MU site, just a simple membership site ... and in the absence of that, I'll settle for a login that actually works and lets my users post to the Forums.

  • vingogly

    Well, I throw in the towel on fixing the problem on the live site ... I'm working on manually recreating my site in a QA installation, and when done and tested will migrate back to my live installation with BackupBuddy. Painful as this is, I suspect it's going to be easier than figuring out a fix for the live version. Will post back results and mark if resolved. Of course, if I manually duplicate the site and the problem still exists, well, that will tell me something, too. :slight_smile:

  • Kimberly

    vingogly,

    Painful as this is, I suspect it's going to be easier than figuring out a fix for the live version.

    This is probably the better route as well, as it will prevent you from dealing with any future peripheral issues that may arise from your old plugin installs.

    I'm sorry you had to go that route but glad it is working for you now!

    So much better to start fresh when you can. :slight_smile:

    Let me know if I can be of assistance.

    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.