Sign in problems – Google – Twitter

Just installed comments plus and love the functionality but having an issue with signing in with Google and Twitter:

After authorization it returns to the comments form but the button is still there and the form is not open. This is only the case with Google and Twitter from my testing.

Have inserted the api keys for both Twitter and Facebook and the form is showing up fine as you can see here:

http://astronomyrecords.com/indian-dream-soundtrackrelaxation-music/

Can send my WP login if needed.

Thanks for your help. :slight_smile:

Server and WordPress info:

PHP information for http://astronomyrecords.com

max_execution_time: 30

max_input_time: 60

file_uploads: 1

upload_max_filesize: 64M

post_max_size: 64M

register_globals: 1

safe_mode:

allow_url_fopen: 1

eaccelerator.enable:

Other information:

PHP Server API: cgi-fcgi

WordPress Version: 3.2.1

WordPress Blog URI: http://astronomyrecords.com

WordPress Installation URI: http://astronomyrecords.com

WordPress Theme: /wp-content/themes/boldnews

WordPress Permalink Structure: /%postname%/

WordPress wp-content directory is writable

WordPress does not use Gzip Compression

WP-Cache is running on this installation of WordPress

GD library is installed

PHP Version: 5.2.17

MySQL Version: 5.1.56

Browser used: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    I’ve tried it myself and can see that except on Twitter I do get the reply box. However, it doesn’t show my username…

    Have you checked whether this works in the default theme?

    If your app settings are correct (specifically that you’ve provided your site URL) the next assumption is that your theme or a plugin is conflicting…

    Phil

  • herrin
    • New Recruit

    Hi Phil thanks for your reply.

    I just switched over to the default them for WordPress. Twenty Eleven 1.2 and turned off every plugin except comments plus of course. So now they all work fine except the Google one keeps going back to the button Login with Google.

    I have to switch everything back unfortunately caus this isn't a testing blog.

    thanks again,

    Herrin

  • Philip John
    • DEV MAN’s Apprentice

    Okay, thanks for doing that. That does tell us that it’s a conflict then.

    You’ll now need to find which plugin/theme is causing it. So revert to Twenty Eleven again, but leave plugins on. If that fixes it, you know it’s the theme conflicting.

    If not, go de-activate each plugin one at a time, checking to see if the issue is resolved. You’ll then find the plugin that’s causing the issue.

    Phil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.