Simple Ads only shows 2 ads when set to show 3

I have simple ads running in network mode. It offers settings to select how many ad units you want to run. For adsense 3 is optimal. No matter how much content there is on a page, it is only showing 2. http://mikessingersongwriters.pinestreetnetwork.com/carly-simon-and-her-never-been-gone-album/
How can I get it to show 3 as it should? I definitely have it set to "3".

Also, it does not distribute ads well on pages which are auto generated. The following page example is a list generated by the site categories plugin. http://pinestreetnetwork.com/pine-street-network-sites/mikes-players/
How do you go about getting it to recognize content other than body text?

    Tyler Postle

    Hey Clayton,

    Hope you're doing well today.

    There are just the two locations for ads by default; however, I think a better plugin for your usage case here would be In Post Ads: https://premium.wpmudev.org/project/in-post-ads/

    It will allow you to better define where the ads show up within the posts.

    Keep in mind it does still limit to within the body content; however, it does give you per post option to turn off the ads too.

    How do you go about getting it to recognize content other than body text?

    What other content are you wanting it to recognize?

    Look forward to hearing back!

    Cheers,
    Tyler

    Tyler Postle

    Hey Clayton, apologies for the delay here!

    I was actually confused by that for a second too lol, but it's for the archive pages. It will show the ad before/after each post, up to the number of ads you allow.

    I've played with In Post Ads, but, if I recall correctly, it has to be activated at the site level. I need to be able to automatically push ads to every sub-domain site by default.

    You're correct, the ads are setup per site.

    The other content would be things like the list generated by the site categories plugin; like in the example link I sent.

    I see what you mean here, it displays both at the top no matter what.

    I'm going to flag one of our coding experts here to see if we can provide a solution for you on this.

    Either myself or the developer will reply back here once we have an update on that

    Let me know if you have any further questions in the meantime.

    Cheers,
    Tyler