Site crashes immediately on activation

As soon as the plugin is activated via the WPMU Installer or standard install its all 500 all the time..

Looks like the activation routine didn't install any tables. The error logs are showing

[Sun Mar 20 03:10:32.057670 2016] [:error] [pid 4991] [client 127.0.0.1:46366] WordPress database error Table 'wp_mp_product_attributes' doesn't exist for query SELECT * FROM wp_mp_product_attributes made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), Marketpress->register_custom_types, MP_Product_Attributes->register, MP_Product_Attributes->get, referer: http://iserimages.com/wp-admin/update.php?action=upload-plugin

  • Luís
    • Support

    Hi @danieliser,

    Hope you're doing well today!

    We have a similar report from other user, that solved it creating the tables in the database:

    https://premium.wpmudev.org/forums/topic/database-error-when-using-marketpress#post-1045328

    If you don't feel comfortable in doing this, can you send us the FTP and cPanel credentials?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - cPanel credentials (URL/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Cheers, Luís

  • Luís
    • Support

    Hi @danieliser,

    Hope you're doing well today!

    I am not sure if this can be considered as a bug, but, we have some reports about this behaviours and the developers are aware and working to avoid them in the next plugin updates.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • danieliser
    • Flash Drive

    Hey Luis,

    I have partially tracked down the issue. I would be happy to test a bit further, but it seems that during activation a request is made for the tables before the db_delta function that installs them is run, this results in a halting PHP error meaning that the tables don't get installed.

    The reason it only occurs sparsely is because most users don't have WP_DEBUG enabled by default and error reporting disabled meaning PHP will continue to run through them.

    I think that may be part of the issue. Maybe simply placing @ before the calls in question would resolve the issue.

    Anyways happy to dig into it next time I run it.

  • David
    • New Recruit

    Hi Luis,

    I ran into this problem today with a new WP multisite install running with PHP 7.0 under IIS 8.5.

    Exactly the same tables were not created and my debug logs are identical to Daniel's. Creating them manually (and removing the deprecated payfast.php file which breaks under PHP 7.0) allowed me to use the plugin with no obvious further issues.

    The error occured for me with or without WP_DEBUG enabled.

    I know IIS is not officially supported but I thought it was worth sharing in case it helps you find the problem.

    With regards,
    David

  • Ivan Shulev
    • The Bug Hunter

    Hey David and danieliser ,

    This is odd behavior and I am not able to replicate it on my environments.

    Could you please share a bit more about your server configurations and hosting providers?

    PHP version, server (Apache, Nginx, etc.), database name and version and other details would be helpful.

    It sounds like the plugin is not able to create the tables due to a restriction from the database maybe?

    If it was crashing for all users we would have had a wave of complaints and this being a relatively limited occurrence is leading me to believe the issue is not in the plugin, but I might be wrong :slight_smile:

    Thank you and I wish you an awesome day ahead!

    Ivan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.