Site De-activated, products still show in global products

Even after the sub-site has been de-activated, the products still keep showing up in the global products at store.elanws.com - scroll down.

The whole point of de-activating a site is because they decided not to continue with it ... so their products should NOT show up in global products.

  • Dimitris

    Hey there Erum,

    hope you're doing good and thanks for reaching us!

    I just tried to replicate this state in a test environment and I did with success, meaning that I can confirm the issue here.
    I already created a bug report for our dev team, let's hope that this won't require an extended time so we can have a hotfix/workaround. Again, can't promise an ETA on this, your patience is highly appreciated! :slight_smile:

    Warm regards,
    Dimitris

  • Panos

    Hi Erum ,

    Could you please try replacing following files that I have attached here:
    wp-content/plugins/marketpress/includes/multisite/class-mp-admin-multisite.php
    and
    wp-content/plugins/marketpress/includes/multisite/template-functions.php

    I would recommend to first keep a backup of these files before you replace them. After replacing you will need to deactivate/archive/spam blog again in order to not show it's products in global store page.

    Please let me know how this works for you :slight_smile:

    Thanks!
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.