Site description disappears when new edits made

I wanted to add a table with content to the site description area in the top right-hand corner. I am able to paste the below code in the site description field in theme options and it looks fabulous. However, when I go in and make later edits to any of the many theme options areas (not just the SEO page) and save them, the header content disappears. This is just pesky for me, but will be downright unacceptable when I turn the site back to my client. I'm thinking I could past the content into some file somewhere, mush like I do with the footers, but my guesses have been failing miserably. Any suggestions? Help!!! --NV

<body>
<table width="100%" border="0" cellspacing="0" cellpadding="0">

<tr>
<td><p class="style7"><span class="style5">477 N. El Camino Real
Suite C202
Encinitas, CA 92024
Click for directions</span><span class="style1 style2 style10">(866) 656-9221</span></td>
<td><p class="style6">3909 Waring Road
Suite B
Oceanside, CA 92056
Click for directions
<img src="http://02aa780.netsolhost.com/wp-content/uploads/2011/08/fb_logo.gif" width="17" height="17" border="0" alt="Morris Eye Group is on Facebook" /> <img src="http://02aa780.netsolhost.com/wp-content/uploads/2011/08/twitter_logo.gif" width="17" height="17" border="0" alt="Morris Eye Group is on Twitter" /> <img src="http://02aa780.netsolhost.com/wp-content/uploads/2011/08/yt_logo.gif" width="17" height="17" border="0" alt="Morris Eye Group is on YouTube" />
</td>
</tr>
</table>