Site displays Warning message then loads on refresh

Hi, my site has started to show this warning when the full domain http://www.bayvetgroup.co.uk is typed in. Warning: mysql_num_fields() expects parameter 1 to be resource, boolean given in /home/ourvetsite/public_html/wp-includes/wp-db.php on line 3026. If you then refresh the page it loads normally. If you type bayvetgroup.co.uk the message is permanent.

this error started when I deleted some plugins that I no longer use and updated ot the latest edition of wordpress. I have updated all plugins and tried general troubleshooting. Other sites using the same theme on my multisite install seem to be fine at the moment

Any ideas/thoughts please?
Thanks
Chris

  • Predrag Dubajic

    Hi Chris,

    Hope you're doing well today :slight_smile:

    This issue is usually caused by some third party plugin, you mentioned that you already tried basic troubleshooting, this means that you tried disabling your plugins already?

    You may want to try reinstalling your WP installation by downloading installation files from wp.org and replace the current files, but make sure you leave your current wp-content folder as well as wp-config.php and .htaccess files.
    I also strongly suggest that you make a full backup before doing so.

    You can also disable front end warning messages and store them in log file by editing your wp-config.php and replacing define('WP_DEBUG', true); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    This should create debug.log file in your wp-content folder instead of showing it on your site directly.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.