Site down to Redirect Issues - Just started after updates...?

Hello Awesome WPMUdev Team...

Looking at defender and warnings in site monitoring (Awesome hiaving that BTW - Thak you!) a redirect issue has just begun and the site is down to due this...

The direct https:// works great it seems .. I have read the foruems and been tryiong to figure out for 2 days but alas I am stuck.

Please help?

Jonathan

  • Jonathan

    Hey Jude,

    That was just fun to say - Very Beatles. ????

    No the issue still exist - I went Incognito and typed http://SXDI.org (not https) and it has the redirect issue as well as used tools.pingdom.com http://SXDI.org and SXDI.org without any routing to test and it throws the too many redirects error again.

    Thank you for your help - I am lost / can't figure out what happened or changed ?

    Again - super appreciative and any insight will be wonderful.

  • Jude

    Hey Johnathan,

    So sorry about the delay here !

    If this is the main site then you'd want to first temporarily set that to something else as shown here and then you'd be able to edit that and then switch back.

    https://halfelf.org/2014/switching-main-blog-multisite/

    If its not the main site, then make sure you are an admin on the site before trying to edit the site url field

    Once again, thanks for the patience

    Cheers
    Jude

  • Jonathan

    PLEASE PLEASE HELP?

    I followed the instructions on the post you sent and it didn't work... so I changed everything back to blog 1 as the defined main site - BUT now the main site is down - PLEASE PLEASE HELP?

    I can't do anything as ALL Super Admin in access is gone as well from all accounts - as in there is NO Super Admin any longer either.

    Here is what I did: Changed the WP-config to Site 2 as current site ... went back to site and the changes didnt happen and I wasnt able to edit the MAIN SITE as the pos you shared with said I would ... so I went back into wpconfig and changed it back... Then site went down.

  • Jonathan

    Please please help - This is still an issue and it has consequences across the entire system...
    including this error from Defender when trying to check blacklisting: It appears that your home_url setting is trying to redirect to another domain. This often happens when you are forcing https but haven't updated your site setting for that. Please verify that the home_url option of your WP install is correct, then click refresh updates in the Dashboard plugin."

    Here is what I have done and nothing has fixed the main site from being http:// instead of the httops as it should be:

    (1) I followed the instructions in the artocle you gave - Changed the main site to another site; edited the current main site to https; saved it and changed it back to main site - It reverted back to HTTP

    (2) Changed the define (home and site) site in wp_config ... Still no change

    (3) Edited the actual tables - Options; Meta for site URL and Home to https... No change.

    This is a huge issue as we are trying to launch and I have been begging for help since the 11th... PLEASE HELP?

  • Jonathan

    No Luis we still have these issues and they are consequences of the moan site being "http" nit "https" ... Please readbyheiygbthebthread and see images.

    It creates a redirect and it doesn't need to - I used the method of changing main site - editing current and saving it and then changing back to main - it reverts back to http...

    I went into tables and changed ... Still http

    Can't use defender blacklist checking because the site redirects...

    Changed the php - still http...

    When we create new sites - they pull from the main site and are http (of course we manually change them but that doesn't solve the isuue) or other issues including CDN issues etc

    There is an image attached in thread: network admin > sites > edit site: SXDI.org

    You can see that it shows http - we have no idea where it is pulling that from as everything else we have tried says https.

    Please help??

  • Luís

    Hi Jonathan ,

    Hope you're doing well today!

    Let me try understand it better:

    1) You want to redirect your main website (SXDI.org) to the HTTPS version;

    It's working correctly. I tested it and all the versions are redirecting to the HTTPS version;

    2) In network admin > sites > edit site: SXDI.org (info tab) it shows HTTP, but in the Settings tab it shows HTTPS.

    Have you tried the solution given in this topic?

    https://wordpress.org/support/topic/steps-for-changing-wordpress-multisite-installation-ssl-secuire-http-to-https

    Note: Make always a backup of your database before make changes, just to stay in the safe side.

    Can't use defender blacklist checking because the site redirects...

    What error are you getting when enable the "Blacklist Monitoring" feature? I tried to enable it in your website, but didn't got any issue.

    Cheers, Luís

  • Jonathan

    Luis,

    As I said in the response above -and have been saying for 21 days now...

    The site is redirecting because I disabled varnish BUT that is not a fix that is a quick fix so my site was not down while waiting on you.

    So the site redirects now but not a fix - as I have stated clearly above that this was as symptom not the cause.

    I have attached images of the cause and the Http (vs. HTTPS) issue.

    I did try using method in post - as I also explained and exactly what happened and the issues with defender - I also explained the error and attached a screen shot.

    I am very frustrated - with the issue and now with the support. That is surprising as typically wpmudev is awesome.

    Now I am trying to go to Cloudflare and can't do that or anything else until this is resolved and am getting no help?!

    Access to site has been granted - login info to server is in notes.

  • Jonathan

    The site is DOWN now to SSL issues again!

    Just enabled CloudFlare and through Hummingbird API and disabled KEYCDN (CDN Enabler Plugin) ...
    I don't know what else to do - I have begged, pleaded and asked over and over and over for help.

    I am attaching yet another of image of the symptoms and the consequences... and now the SITE is down completely.

    Any way I can get some help PLEASE????

  • Luís

    Hi Jonathan ,

    Hope you're doing well today!

    Honestly, this is weird, all the common procedures were mentioned here, I think. In order to try help you better, could you please send us the FTP access so we can give a closer look to the "wp-config" and "htacces" to see if something was missed?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - mysql credentials (url/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

  • Tyler Postle

    Hey Jonathan,

    Luis is away on vacation so hope you don't mind me jumping in on this.

    I've been investigating your site and comparing it with my own multisite that I have setup with https and trying to replicate the issues you're experiencing. I know you're wanting to change that "site address" to https:// but I don't think that is the problem, as the error you mention is referring to the home address that you will find yours already is https:// in your main site edit site settings. I've embedded a screenshot of mine to illustrate, I saw yours was https there as well.

    I tried turning on your Varnish temporarily to see the issue and I did start getting a Cloudflare cache page and was unable to access your /wp-admin - I turned off Varnish shortly after and your site is loading again albeit quite slowly.

    Have you spoken to Bluehost about using Varnish on your setup? Considering you're combining it with Cloudflare among other performance tools like Hummingbird, I would recommend asking them about this as they will be familiar with their own server setup. We aren't system admins here so don't have much experience with that side of things.

    What I can say is that your site was directing to https from http without any issues and setup looked similar to my multisite where I'm not getting the redirect chain error, did you use Google Pagespeed for that?

    Cheers,
    Tyler

  • Jonathan

    I appreciate you jumping in as this is a nagging issue that is getting worse by the day in both frustration and real cost of time and money and user experience.

    As you said the site is super slow and it's an issue that is just not workable. This was not that case before the hummingbird updates.

    I will ask you to do the following:
    Look at the actual site settings - I see it is redirecting - and I see that in the tabs... I want it to be HTTPS:// at the root so that redirect doesn't happen. If you look you will see it is http:// (see screenshots in this thread please)

    I did talk to host and have kept Varnish disabled as the site being http:// them redirecting (as you noted) breaks the site.

    We had all of our CSS and JS combined and the latest Hummingbird now is serving these as individual files (again slowing the site down tremendously) not sure why or how that happened.

    If you disable cloudflare Dev mode and and the. Run tools.pingdom.com you will see the issues very clearly and yes the same issues appear on Google site speed.

    We were running keycdn (before cloudflare) and all was good until the update of Himmigbird (except we still couldnt run varnish due to the mainsite being http at root and redirecting) and then it broke keycdn as well.

    Again I appreciate the help - everything that is coming out leads back to the site being http with a HTTPS redirect combined with the Hummigbird
    Updates

  • Jonathan

    I appreciate you jumping in as this is a nagging issue that is getting worse by the day in both frustration and real cost of time and money and user experience.

    As you said the site is super slow and it's an issue that is just not workable. This was not that case before the hummingbird updates.

    I will ask you to do the following:
    Look at the actual site settings - I see it is redirecting - and I see that in the tabs... I want it to be HTTPS:// at the root so that redirect doesn't happen. If you look you will see it is http:// (see screenshots in this thread please)

    I did talk to host and have kept Varnish disabled as the site being http:// them redirecting (as you noted) breaks the site.

    We had all of our CSS and JS combined and the latest Hummingbird now is serving these as individual files (again slowing the site down tremendously) not sure why or how that happened.

    If you disable cloudflare Dev mode and and the. Run tools.pingdom.com you will see the issues very clearly and yes the same issues appear on Google site speed.

    We were running keycdn (before cloudflare) and all was good until the update of Himmigbird (except we still couldnt run varnish due to the mainsite being http at root and redirecting) and then it broke keycdn as well.

    Again I appreciate the help - everything that is coming out leads back to the site being http with a HTTPS redirect combined with the Hummigbird
    Updates

    • Tyler Postle

      Hey Jonathan,

      Look at the actual site settings - I see it is redirecting - and I see that in the tabs... I want it to be HTTPS:// at the root so that redirect doesn't happen. If you look you will see it is http:// (see screenshots in this thread please)

      I had a close look at this with one of our developers and If someone enters http:// or no prefix then it MUST redirect. There is no getting around that because when someone enters that in then your browser will attempt to reach that url, but your site is set to force https, so it will then redirect to https instead.

      If you type https://sxdi.org then you will see that there is no redirect chain for http://sxdi to https://sxdi - this is because the forced prefix was entered.

      Your siteurl and home url are already set to https too. That http:// site url address in the info tab shouldn't make any difference for you. It is set like that on installation - you've already changed the necessary urls to https.

      If you disable cloudflare Dev mode and and the. Run tools.pingdom.com you will see the issues very clearly and yes the same issues appear on Google site speed.

      I see Cloudflare dev mode already is disabled and I'm running the pingdom test and it is taking a long time to load, but even when going directly to https:// it still is, so I don't think that http is your issue here. Is there something else I'm missing in the pingdom test?

      Cheers,
      Tyler

  • Tyler Postle

    Hey Jonathan,

    Why is that NOT https?

    It always defaults to http on installation, this is part of the core WP code.

    Essentially that field just makes your siteurl/home and other urls in your site https without you needing too, but since you have already manually made all those urls https then that "site address" field won't do anything. You've overridden it. Changing that field to https won't make any difference for you.

    You can use the filter in esc_url function to change it but that function is used globally and it would mean changing the core code so you would need to change it on every update. Again, changing this won't make ANY difference for your site either.

    The issues you have are related to something else. I went to your site again and got a 502 bad gateway error again, which is related to your host so I would report that to your host as they can look at your server resources and see if you are hitting limits that are causing it.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.