Site edits vanish in Upfront:Fixer

Dear Support,
For several days I have been experiencing data loss while attempting to develop a site using Upfront:Fixer. Losses include global regions, changes to page layout changes, and sometimes CSS code. I experience these scenarios when trying to save a page and/or open an existing page/post for edit within Upfront:Fixer.

I have taken some notes about my experiences editing with Upfront today. Once again, I did a boatload of work on the site and then for some reason it all vanished - again.

Start:
I perform edits on the home-page via the Upfront editor -> save edits. Then open another Upfront (none template) page, perform edits -> save. Next, I attempt to edit home again via the Upfront edit page interface. On first attempt to open Home, a page with a Archived message screen with blue background with my posts listed under it displays (attached: archive_error.jpg) - I am careful not to save this erroneous page, I try to reload the page a few times then eventually get to my Home page edit screen but now my custom global footer region that was previously there (attached: correct_layout.jpg) is missing (attached: revert01.jpg). This madness of regions vanishing and malformed page edit views seems to go on and on.
Sometimes the global regions I created are replaced with the default fixer regions (see attached) other times there is no region displayed. And often, the global regions I saved vanish from the system and need to be recreated again.

Next:
Then I make edits to another page on the site.
I modify the logo and footer global regions. Save the page and then I notice the following messages popup:
Cleaning Region CSS
Region CSS cleaned

Next I create a new page using a theme template page:
I add two feed elements and the global footer region I created, then remove the default Fixer footer.I try to save the page, its hangs on save for an uncomfortable amount of time, then I see the following messages popup:
Theme colors could not be saved
Theme color styles could not be saved
(I made no changes to theme colors on during the edit)

Eventually I am able to save the page.

End:
After several more page AutoBlog feed related I was happy with progress and took a Snapshot of the site. Next I re-enabled the Chat plugin and boom! My custom Global regions were all gone - again!

I figured that I could just restore the Snapshot that I took a few minutes before activating the plug in - but even after restoring it, the global logo and custom footer regions still not displayed.

And to finalize the annoyance, the 2 global regions that I created and saved, logo-region and custom footer are both GONE from the system.

If I am doing something that is causing the system to behave this way, somebody please fill me in. I have lost days of work, and seem to be stuck in a loop of re-applying changes that simply vanish.

Please advise!

Cheers...

  • Thomas Sarkisian

    I started to work on the site again today, and once again the footer that was displaying last night is now gone. When I create a new page, the default Fixer header region displays instead of the global header region that I created, furthermore it no longer in the region list. The same with the footer region, it is no longer available in the global region list.

    Can somebody please help me out here? Is this a hosting issue, or do I simply need to use another theme? Based on what I am experiencing Upfront:Fixer is not stable. I can not make any progress with changes simply vanishing all the time.

  • Thomas Sarkisian

    Another screen cast showing more of the oddities I described earlier in this thread.
    http://www.videosprout.com/video?id=5e04446d-4077-4281-92ed-55052f5f368a

    The video starts on a single post page.

    You see at the top of the screen I am only seeing the header I made. The global region logo-content is not showing here or on the font page as of today but it was there when I stopped working at 2am last night.

    Scrolling down you can see the takfiri-footer global region I made, that normally shows on all posts and pages. But has since vanish again from my front page.

    Next I open the Global Regions drop-down selector. Neither of the Global Regions I created and saved (many times) is showing. Nor is the footer we can now see on the page.

    Moving on…I try to open the home page and Boom! I get that bastard Archived box page, note, my posts are all listed under it, but the format is wrong, they are listed in Blog page format whilst on my home page there are 2 post elements displaying 2 columns of posts.

    And…again, the default Fixer sub and footer are showing up.

    Next I refresh…Now, this for some reason is taking much longer than normal, I guess the internet in Bangkok decided to put on a show for us, during the delay my mouse batteries crapped out so I changed them.

    After the refresh delay, you’ll notice that the Upfront Editor does not invoke, this happens very often - and is also where I am most likely to notice that Global Regions begin to vanish. I have to go out to the WP dashboard and back in again to get the editor fired up again.

    Cheers...

  • Jack Kitterhing

    Hi there @Thomas Sarkisian,

    Hope you're well today and thanks for your questions, it doesn't sound like you are doing anything wrong at all.

    Could you let me know who your host is please? Also do you have any form of caching, on the site or server side?

    Is there a certain amount of time it takes until the site changes back/data is loss, for example every 12 hours, if so it's possible there's a process running that deletes the data.

    I'm here to help. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Thomas Sarkisian

    Dear Jack,
    I greatly appreciate all the support you guys have been providing. I hope we can get to the bottom of the problem soonest.

    I am helping friends out with this site, as I understand it is hosted on a provider in Spain, however I believe they are reselling for a US company. The site plan (D3Medio) is listed here:
    http://digital3host.com/promocion-d3medio/

    There are no cache plugins installed, and the hosting only provides basic panel options, I did not notice anything cache specific.

    What are you thoughts about hosting on Deamhost? I have a plan with them and could migrate the site there if necessary.

    Cheers Jack!
    /Thomas

  • DavidM

    Hi there Thomas,

    Yikes, so sorry for that previous post! I think I just completely misread the number there, it's actually PHP 5.2.4 that's the minimum requirement now, so you should be fine.

    Could I ask if your web host gave any details as to why they think the issue is due to the PHP version?

    PHP 5.4 is still recommended, but not required. It might possibly fix things up by upgrading to that. But 5.3 should technically work unless there's something else on your site that's requiring something more recent.

    Looking forward to your reply. :slight_smile:

    Cheers,
    David

  • Jack Kitterhing

    Hi there @Thomas Sarkisian,

    Hope you're well today, I don't believe upgrading the PHP version would make any difference to be honest, though it won't break the install. But I'd always recommend backing up the site before upgrading.

    Has the data reset anymore? Could you send me through the following please?

    Can you please send in:

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing

    Hi there @Thomas Sarkisian,

    Hope you're well today! Thanks for sending through the details, I've been taking a look at this for you, I've checked all Upfront data within your database and that is all correct.

    I've then checked the footers across all pages, I've set that to global, so now the footer should save, by default it should be global, but it appears this was edited. Could you try setting the footer as you want it now and let me know if it works? :slight_smile:

    @Arthur I see my colleague Predrag is responding on your ticket, I'll check it too. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Arthur

    Thanks, Jack! As you may have seen on the other thread I've managed to get things to work by replacing pages and posts and all new ones use the global regions. There is still an issue of stability, with things reverting or the browser not finding an image, but at least things seem to be looking as I want them now.

    By the way, Thomas, I've upgraded PHP several times on WP installations, including Multisite, BuddyPress, you name it. Unless you are using old plugins which have not been updated by the developer there should be no problem upgrading, as hopefully you've found by now. It's always a good idea to keep server software reasonably up-to-date (though never "bleeding edge" on live sites!) And if there is an old, un-updated plugin, it's worth finding a new one as sooner or later it will cause problems with the rest of WP anyway. I try to stick only to WPMU plugins wherever possible as we are guaranteed compatibility between them and we get top notch support!

    Cheers!

    • Thomas Sarkisian

      Dear Jack,
      Was I doing something wrong then? If so, I'll need some explanation regarding the creation of global regions.

      I had clicked on the + at the bottom of an existing region, then selected new region, named it, and checked make it global. Everything would work fine with new pages and posts for a while - say until the next day. Then they were simply not there on pages nor were they selectable in the Global Region drop down - they were simply gone.

      That has happened many times already. Either I am doing something wrong, or there is something else causing this to happen.

      Cheers...

    • Thomas Sarkisian

      Dear Author,
      I appreciate your feedback. I too do not believe my issue is resolved. I have lost numerous header/footer changes already. My steps were to create a new region, and check 'make global'. The new regions were then available for the edit session and I proceeded to build out new pages. But...the next day, the header/footer I created was not displayed on pages. It was either replaced by the default element or just not there at all. Not only that, they were not even selectable via the global region drop-down menu. It was as if they never existed in the first place...Again, this has happened many times. I am now reluctant to create new ones. This is a major problem, the site I am developing is now on hold and the client is irate!

      I am not sure what to do about it...

      Cheers,
      /Thomas

  • Arthur

    Hi Thomas,
    I think there must be some general instability in the system as, for example, I sometimes have the editor freeze or options not appear (such as when trying to edit background regions the screen appears greyed out and I have to refresh the page).

    Your case seems more extreme even than mine, as mine seems to have "settled down" now, though I did have to recreate a couple of pages. It seemed to be that having made regions global, if I then created new content, the new pages and posts correctly used the new regions - I've checked today and it's stayed the same).

    While this is not ideal, I wonder if it's worth one more try on your part to recreate on one page then create new pages (what I did was create them with a new name, copy the content from the old page (in visitor mode, not editing) then go to the main WordPress dashboard, deleting the old pages (they'll still be in the trash in case you need them) and use the "quick edit" function to change the page slugs to that of the old pages, so the links will work again. I hope that makes sense!)

    Before you do that, one thought occurs to me: do you have any caching/memory/speed plugins active on the site? It sounds too regular to be just instability, as if there was a "cron job" (regular, timed server process) running every night clearing data. Try disabling ALL your plugins, make some minor but visible changes, and wait to see if the problem is still there. If they stay we have an answer. If not, we'll have to keep looking!

    Cheers,
    Arthur

  • Thomas Sarkisian

    Hi Guys,
    I had another go at it this evening. I first re-created logo and footer regions making them both Global. Applied them to several pages. Everything was working fine for a while. I went back on forth between the Dashboard and the Upfront editor several times while making minor changes to pages.

    Then I noticed that my posts did not have the header of footer applied to them. I went into one post, added them, then saved - choosing apply to all posts of this type. When I returned to the front page, the footer was gone again from all pages, and it was no longer listed as a Global region. I had to recreate it once again.

    It seems to me that committing region changes to all the posts of that type has something to do with this problem. The global region I had created shortly before was deleted from the system. This is exactly what was happening before too!

    Any ideas?

    Cheers…

  • Arthur

    Interesting theory, Thomas, that may have been causing my problems before. Thing is, with the new parent blog page I created, the global regions appear to be stable. I was able to demonstrate the system to the client and changes to posts, both single and global, saved correctly and everything is still as it should be.

    While what is still happening to you clearly should not be happening (there is clearly a problem there somewhere and you may have hit upon where with the global post update) I seem to have found a workaround. There may be another clue, in another issue I have had, which may support the theory of a problem with the blog template/system. On the homepage and pages using the "blog" template, I have a formatting issue on certain resolutions of mobile device (see this thread: https://premium.wpmudev.org/forums/topic/formatting-on-mobile-white-band-large-font?replies=4#post-864775 ). The pages which use no template seem to be fine but the blog pages have formatting issues.

    Now, when I recreated the "blog" page (it's actually for listing used machinery: http://94.23.30.23/~optigenia/maquinaria-usada/) I decided to try using a blank template, or rather "none" from the list, and manually adding a posts element to the page. This seems to have helped keep the global regions stable. There is still a formatting issue on my iPhone but at least it appears to be stable. Now, even when I made changes to the global footer on one of the other pages (small ones, but ones which before might have affected things) the changes were rolled out to the other pages and have stayed.

    So I have hope that my avoiding the blog template and adding the posts element to a ' "none" template' page, I have found a workaround.

    Try doing that, but make only small but visible changes each time to avoid wasting time if it doesn't work!

    Good luck!

  • Thomas Sarkisian

    Dear Author,
    I too feel that there is a problem with the template/system although I am not using the either of the two templates, I had selected none.
    I am pretty sure that working on pages is stable, that is until I make changes to a post and apply the change to all posts, then the trouble begins. I'll have to test this a bit further when I have more time, I am so far behind as it is and still not sure if I am in the clear.

    Thanks for your feedback! Great to hear from and share experiences with other users.

    Cheers....

  • Jack Kitterhing

    Hi there @Thomas Sarkisian and @Arthur,

    Hope you're both well today, we've been doing some further testing and while we haven't actually been able to replicate yet, we believe you may have found a underlying issue with global regions.

    The lead developer of Upfront is taking a look and will be debugging this over the coming days, due to the complexity of the issue it may take slightly longer than the average issue to resolve, but we are indeed working on it. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Predrag Dubajic

    Hi @Nicolas,

    Sorry to hear you are having issues with upfront, however it might be best if you open new thread even if the issues seem closely related, this help us catch up with everything and help you faster.

    Can you please open new thread and we will do our best to help you out with this, you can start a new thread here:
    https://premium.wpmudev.org/forums/#question

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.