Site hosted with a silver plan is too slow.

I have a sub-directory multi-site hosted with your silver plan. The main site or any of the sub-site is not having major traffic, still, the site is too slow. CPU is always hitting 100%. Please help me fix this.

  • Nebu John
    • Staff

    Hi Edoardo,

    Hope you are doing good.

    On checking site analytics everything seems to be good now. I can see that the load average is optimum and CPU usage is fine. Were you able to run a conflict test as discussed in the chat?

    Please get back to us if you need any further assistance regarding this.

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hi Edoardo,

    As I have mentioned in chat, this is happening because the site is essentially using too many PHP resources either because of bad code or a plugin. So a conflict test has to be performed to identify the plugin possible causing this issue.

    Have you done a plugin conflict test as we have requested during our chat? If not, could you please run a plugin conflict test and let us know how it goes?

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hi Edoardo,

    To further investigate this issue, I appreciate if you could send us WordPress admin credentials.

    Note: Please, don’t leave your login details on this ticket.

    Instead, you can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nebu John

    -WordPress admin username
    -WordPress admin password
    -Login URL

    Kind Regards,
    Nebu John

  • Nebu John
    • Staff

    Hi Edoardo,

    Thank you sending us the information.

    I escalate this issue to our Hosting SLS team to take a closer look at this. We will post an update here as soon as more information is available.

    Please keep in mind that our SLS Team deals with more complicated issues, so it may take a little longer for them to reply here. Thank you for your patience while we look into this further.

    Kind Regards,
    Nebu John

  • Jesus Rivera
    • Staff

    Hi Edoardo ,

    I monitored your site these days and have to said that I agree with my partner Nebu because server is requiring more resources maybe due one or some of your 39 active plugins you have installed have some bad code.

    I’m not sure exactly which plugin is taking those resources as it seems that doesn’t happening in a specific time(at least when i’m monitoring it), I also tried disabling all plugins for a few mins, looks stable and re-enable it and starts fluctuate in cpu/memory usage again. However I see in log that suggest an upgrade your as seen in here:

    Need More PHP Worker

    [25-Sep-2019 23:07:19] WARNING: [pool www] server reached pm.max_children setting (12), consider raising it
    
    [24-Sep-2019 10:39:16] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 16 childr
    en, there are 3 idle, and 10 total children
    [25-Sep-2019 00:48:58] NOTICE: Terminating ...
    [25-Sep-2019 00:48:58] NOTICE: exiting, bye-bye!
    

    Running Out Of Memory
    Sep 21 07:50:33 vinninet kernel: [2592256.087316] Out of memory: Kill process 31650 (php-fpm7.3) score 53 or sacrifice child

    Either case and I as told you if there is really a bad code plugin, maybe upgrade is not a solution, so we have to disable all plugin and enable plugins one by one and deduct which plugin is causing this issue.

    Please let me know if you need something else from me.

    Regards,
    Jesus

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.