Site is blocked by "... is only compatible with WordPress Multisite" message

I just installed the Invite plugin from the MPMUdev dashboard and I was redirected to a blank page with the message: "The Invite plugin is only compatible with WordPress Multisite."

That's no problem, but now that page has hijacked my website. No matter where I try to go, I'm redirected to that page on both the front and back-ends. How should I resolve this?

Thanks for any help!