Site is not displaying

I added an SSL cert. and site is not displaying at all

  • Dimitris
    • Support Star

    Hello there David,

    hope you're doing good today! :slight_smile:

    Could you please inform us about the exact steps that you've made so far?

    If you've installed the SSL certificate in your server already, then this little plugin can be handy in order to force your website to run under the https:// protocol:
    https://wordpress.org/plugins/really-simple-ssl/

    For more info about this subject, you can also advise our relative blog posts
    https://premium.wpmudev.org/blog/tag/ssl/

    Warm regards,
    Dimitris

  • Adam Czajczyk
    • Support Gorilla

    Hi David!

    I just visited you site and I see that it's redirecting to HTTPs but when so, it's actually going to a default GoDaddy's "place holder" page. I think you are hosting your site with GoDaddy so that would actually be a problem with SSL configuration itself.

    Often, the server is set in a way that http and https domains are actually "different space", which means that it could actually be two separate sites (two separate folders). Another similar case is where it shouldn't work like this but requires additional setup on server side because the server actually "doesn't know" where to forward the https requests so they go to a default "catch all" host page.

    I'd suggest getting in touch with the host to make sure that this is set up properly and the domain for both http:// and https:// protocols is using the same root_folder and pointing to the same WP install.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello David!

    The domain name that I see on a screenshot is a domain that you want to map, right?

    From what you wrote, I understand that it's pointed to the server via DNS A record. If so, I'm afraid that wouldn't work here. I checked what's the IP for that domain and then checked the IP itself. There's currently 721 domains hosted on that IP which means that it's a shared IP.

    A domain to map can be directed to the server by IP (via DNS A record) only if it's a dedicated IP that's used for that single, specific Multisite install. In this case you'd need to go a different route:

    instead of IP and A record, you'd need to add the domain to your server as an add-on domain and set its root folder to be exactly the same as root folder of the main domain of you Multisite. As a result - before you map the domain in Domain Mapping putting it in a browser bar would result in loading your main site (or redirecting to main site's signup page). Then it can be mapped and will point to the proper sub-site.

    The other option, if you want/need to stick to DNS and its A record, would be to get a dedicated IP for that Multisite (for the main domain of it) and point A record to that IP.

    Kind regards,
    Adam

    • Adam Czajczyk
      • Support Gorilla

      Hello David!

      I'm sorry, disregard my response above. Apparently while responding I "mixed up" two issues - yours here and one similar from the other Member (from other ticket), in the end addressing your case with the explanation that I should give there. I'm terribly sorry about that and I apologize for causing confusion!

      That being said, I checked the site again with and without https:// prefix. In case of "https://" prefix the site still loads the yourdomain.com/cgi-sys/defaultwebpage.cgi page which is a "default placeholder" page when the site doesn't exist there. That's the same what I wrote in the previous post here https://premium.wpmudev.org/forums/topic/site-is-not-displaying-1#post-1296851 except the automatic redirect to https://.

      When I visit the site via http:// I got the same error as on the screenshot that you shared.

      One way or another, this means only that the SSL is still not setup properly or the domain is not configured for SSL properly. It confirms that the https:// prefixed (SSL secured) domain is looking into a different folder on server than not SSL prefixed.

      Then, if you got the site itself configured to use SSL or there's some sort of redirect from non-ssl to ssl, that might actually be causing the error that you see on the screenshot because the server tries to fetch some resources from the folder where the do not actually exist (instead there's a "placeholder" page there).

      I would strongly recommend then checking SSL and domain configuartion to make sure that in both cases everything's fetched from the very same folder on a server (not by any forwarding but "generically"). It might really be worth getting in touch with the host to have them look at it. Did you ask them about it? Basically, the root folder (aka document root) for the domain must be the same for non-SSL and SSL configuration or - speaking in terms of e.g. Apache vhosts - for 80 and 443 ports.

      Kind regards,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.