Site name doubling in browser top bar

Hi, when you visit my site http://powvets.com the top browser bar (right at the top) shows my site name twice IE:

Gallery | PowvetsPowvets

I have investigated this and it is coming from the Settings - General settings - site title input.

If I remove the site title from this input I get Gallery | -

Same behavior in IE and Firefox

Can you tell me how to fix this please?

Thanks,
Wayne

  • jacksun
    • Design Lord, Child of Thor

    Hi David, I do have an SEO plugin running, infinite SEO, but I have eliminated it from being the problem. No matter what I do with the SEO plugin nothing changes, even disabling it. As soon as I add the site name under Settings - General settings - site title input I get the double site name in the top bar. Once I remove it from there I get the Gallery | -

    I have even removed all the %%sitename%% and other tags from the SEO plugin and there is no change.

    Regards,
    Wayne

  • dfstorm
    • Site Builder, Child of Zeus

    I would be looking in your header.php file of your theme.
    Can you see the line that is generating the documnet title? It will look something like this
    <title><?php bloginfo('name'); ?><?php wp_title('-'); ?></title>

  • DavidM
    • DEV MAN’s Mascot

    You're totally right dfstorm, and I completely forgot about that.

    @jacksun, sorry I missed that one, but it seems this is most likely related to the theme you're using. If you switch to the default BuddyPress theme or Twenty Eleven theme you should notice the issue's not there.

    That said, it's likely your theme is displaying the title tag in a non-default way.

    You might be able to sort it easily by changing the wp_title() reference in it to just a bare function call, as dfstorm posted.

    -David

  • jacksun
    • Design Lord, Child of Thor

    Ok, so this is what I have:

    <title><?php wp_title( '|', true, 'right' ); bloginfo( 'name' ); ?></title>

    and this i what dfstorm wrote

    <title><?php bloginfo('name'); ?><?php wp_title('-'); ?></title>

    When I use what DFStorm wrote I get

    Powvetspagex | Powvets

    So I messed about a bit and did this:

    <title><?php wp_title( '|', true, 'right' ); ?></title>

    And it seems to work. Any possible issues with removing the <?php bloginfo('name'); ?> code?

    Thanks,
    Wayne

  • DavidM
    • DEV MAN’s Mascot

    Hi Wayne,

    I don't see any issues with that myself.

    That one's really a matter of how you want it all to work. If that works for you, there's really no reason that wouldn't work well. You're basically at the code level of customizing the SEO options. :slight_smile:

    -David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.