Site not loading in Firefox and Admin not accessible in any other browser

My website will not display in Firefox.
The site WILL display in Chrome, but the Admin page will not (http://hardcheapknock.com/wp-admin/). The console says "Failed to load resource: the server responded with a status of 500 (Internal Server Error)"

I did receive an email that the site was upgraded to WordPress 4.9.8 yesterday.

  • Nastia
    • Support Rock Star

    Hello Gunderstorm

    I trust you're doing well!

    On the wp-admin page on your site, in both browsers, a 500 error shows up. It is possible that some plugins on your end are not compatible with the new updated version. Would you please access your site's folders, go to the /wp-content/plugins/ and rename the /plugins/ folder to /plugins-deactivate/.

    See if the wp-admin page is loading. If all is well, create new /plugins/ folder, and move plugins' folders from /plugins-deactivate/ to /plugins/. You can move them one by one or in groups, check each time, when the issue occurs again.

    Make sure not to load the WordPress Plugins page, this will deactivate all the plugins from the database.

    Let us know how it went!

    Cheers,
    Nastia

  • Gunderstorm
    • Design Lord, Child of Thor

    Thank you, Nastia. I had not heard of this method of troubleshooting plugins. I will file this away for future use!

    The good news is, I have narrowed down the offending plugin. The BAD NEWS is it is WPMUDEV's Hustle that is causing the conflict.

    The plugin folder which triggered the error is /plugins/wordpress-popup/.

    Is this something you can take to the dev team and report on?

    Thanks,
    Craig

  • Gunderstorm
    • Design Lord, Child of Thor

    Hmmm... I just realized that wordpress-popup may have been a beta version of Hustle. I believe I acquired it from a support ticket back in July of 2017.

    I attempted to install the several recent versions of Hustle and encountered the same error.

  • Nahid
    • Tech Support

    Hey Gunderstorm !
    Hope you are doing well today!

    I wasn't able to replicate the issue with Hustle and the latest version of WordPress (4.9.8) as I tested in one of our test sites. This seems to be specific to your installation only. In order to determine the source of the issue, we'll need more troubleshooting details. Could you please enable debugging in WordPress by putting the following constants in the wp-config.php file?

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    These constants must be added before the line "/* That's all, stop editing! Happy blogging. */" for them to work. Please make sure identical constants are replaced if they were already there previously.

    Enabling debugging in WordPress will log any errors that the site encounters in a log file named "debug.log" located in the "wp-content" folder. Please upload the debug.log file in a cloud storage platform like Dropbox and attach the shared link in your next response so that we can take a look into it. You can know more about WordPress debugging in this handy article.

    Note: It is highly recommended that the site is backed up before the test or the test is done in a cloned staging site.

    Hope this helps. We'll be looking forward to hearing from you. Thanks!

    Kind regards,
    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.