Site now routed bizarrely to hosting catch page

I have a multisite install located at dem.co
a site in the network is called ag
the address for this is /ag/

I mapped a domain to it to test the plugin and had success.
Now I have removed the plugin (after removing the mapping)

Now when I visit the http://www.dem.co/ag/ site it jumps to the hosting provider "error page" for lack of a better word.
I have a dedicated IP address which is the root page for dem.co

at the time of this posting, I edited the site called ag and changed it to agri and it comes up as it was designed.

but if you go to /ag/ it still shows the hosting catch all page.
If you substitute an unknown "site" a 404 error page shows up as it should. Example: http://dem.co/billyrivers/

I have worked around the issue by renaming the site, but I really want the site to be /ag/ as it was originally set up.

  • wpcdn

    Maybe when you removed the mapping (by changing the A record back to its original), the newly revised record hasn't propagated yet?

    This would make sense:

    - Domain record goes to the name server.
    - Name server refers the request to your WordPress installation (because the A record is still pointing there if the change hasn't propagated yet).
    - Without the domain mapping plugin to direct traffic on your WordPress installation, the request simply goes to the default/error page.

    Mark

  • cjon316

    Well, all i did was remove the mapping within the wordpress install. I didn't change the a record anywhere. If anything, the /ag/ site if cached, should have gone to where the domain was pointing earlier.
    The /ag/ site never pointed to the hosting catch all page until after using the mapping plugin.

    I do not have any type of caching plugin on the install anywhere. I get the same results from any browser, so I don't think it is workstation related.

    I don't know how dns could play a part if I haven't changed the a record.

  • wpcdn

    I don't know how dns could play a part if I haven't changed the a record.

    How did you map the site to your WordPress site? The way to do that is by changing the A record to point to the WordPress installation. Then the domain mapping plugin intercepts the request and directs it to the proper sub-site.

    So, if you changed the A record originally to enable mapping, everything should have worked fine.

    You said that you removed the mapping, which I assume to mean that you changed the A record back. But DNSs cache records for up to several days. So if the modified A record (that you set up to map the domain) is still residing in domain name servers, that domain could still be effectively pointed to the WordPress installation. And, without the domain mapping plugin there to direct traffic, it is possible that the request is going to the default/error page. I'd think that it would go to the main site, but I've seen this kind of behavior before.

    If you never changed an A record, I'm not sure how you achieved (and turned off) mapping.

  • cjon316

    I don't understand how I am missing this one.

    I am talking about mapping a domain to a site in this case /ag/ the domain mapping worked perfectly.
    This is because I have done all the proper setup with the dns with the a records, and everything else.

    I am reporting this bizarre behavior because after I removed the mapping from the site (inside the sites tools mapping menu) then it began to behave as I have stated in the prior thread.

    I know people want reputation points, but this is not very good to come rushing in here to find out that the response I got to my last post was merely a watered down question about how I set it up in the first place. I am confident that I explained that the mapping was working perfectly.
    I am not certain that this bodes well for the cost of membership when the members can't offer anything better than reboiling the question.

    In an effort to solve the problem in a speedy fashion, I need to get some actual advise from someone who understands what I am actually talking about.

    Help? Please?

  • wpcdn

    @cjon316, if you're referring to my post, which it appears that you are, it certainly wasn't as you describe it...in terms of the post content or my intentions.

    Domain mapping requires things at both ends, and I was trying to analyze what you had done at both ends. I wasn't trying to get rep points...I just spent over an hour offline helping someone else with a domain mapping issue. That person had originally offered to pay, but I did it free and didn't ask for anything in return.

    If someone takes the time to try and help you, and you don't like the help, just ignore it. Don't complain about it, and don't insult that person, as in:

    I need to get some actual advise from someone who understands what I am actually talking about.

    That kind of attitude makes people less likely to help other people.

    </rant>

  • cjon316

    What is strange to me is that the ag rv and tc sites all worked flawlessly, until I installed domain mapping. Now even though I have removed the mapping elements from the server, the 2 letter sites all route to the hosting page. (Which they never did before the mapping plugin was installed.)

    What is the nature of the mapping plugin that it can cause existing sites which work properly to now be routed to a hosting page whether they have been associated or mapped to a domain?

    @wpcdn. I am not ungrateful for your help. I was merely referring to someone who had not read the thread before asking the same questions which had been answered.

    Is there an actual minimum length for site names? Because that is what I am dealing with here. Sites are named with 2 letter names. Not usernames. I am not certain that there is a minimum limit of 4 characters either. Can this be explained?

    I am hoping that the creators of this plugin will read the thread and weigh in on what actually might be happening. At this point I am concerned that I will ever get the problem solved.

    I would offer this: Is there any type of minimum standard that needs to be in place, including server settings, etc. for this and other wpmudev plugins to just work? I wonder if there is any type of script like a php audit file that could be run which would show me what is missing. If that is even the case.

    Again, I will say this. the sites were all working just fine (including those with 2 letter names) until the mapping plugin was installed on the site. I have also been troubleshooting the multi-domains plugin which I cannot get to work at all. (The mapping plugin did actually map a domain properly, but when I removed the mapping, the site underneath it stopped working.) But I have never been able to get the multi-domains plugin to work successfully yet.

  • cjon316

    Aaron, thanks for your reply, and rereply.
    I don't think that is a solved issue yet, because there is still the problem with other sites that have never had problems before, now not working.

    The /ag/ folder has been deleted as you said, but that is the actual name of the site that I want. Does the sites system within the 'network' install create a folder for each site and add some stock wp files?

    As I have stated, the one thing in common with the sites, and the trouble is that I installed the domain mapping plugin, and removed it again. Before installing it, the sites I had created within my multi site install were all working fine.

    Then I tried the multi-domain plugin with no success, ( i have a separate thread there) then installed the mapping plugin which actually worked in the sense that I actually mapped a domain to a site. I wasn't quite ready for that to be live, so I disassociated the domain with the site, and now the site itself doesn't work.

    This topic is not resolved. Please help?

  • wpcdn

    . Sites are named with 2 letter names. Not usernames

    .

    Well, in WordPress multisite, username generally equals site name. So if a user signs up with the username "myname", their site would be located at:

    http://yourdomain.com/myname

    If you create a site in Network Admin via Sites > Add New, it's referred to as the site name instead of the username, but WordPress sees it the same way.

    The four-character minimum is mentioned on the WordPress registration form.

    The /ag/ folder has been deleted as you said

    To help troubleshoot: When you created the /ag/ site that you mapped to, how did you create it?

    - Via the WP registration form; or
    - Via "Sites > Add New" in Network Admin; or
    - Manually creating the directory and then adding content (or a separate WordPress installation) to that directory?

    Mark

  • cjon316

    Thanks for your reply.
    I understand that the mapping plugin didn't create the folders.
    Does the actual creation of the sites under network admin create a folder with the same name?

    I will delete the folders if wordpress didn't create them. But I don't know how they got created in the first place.

    Last week when troubleshooting in the chat, the wpmudev rep logged in and created a site under the primary domain called test.

    Now under the wordpress install, there is a folder called test.

    Are you saying that creating a site will not create a folder?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.