Site restore not working

I attempted to restore a site from a Snapshot backup as a test of the plugin. There were no errors but the site is still in the same state it was before the restore. Basically, the restore seems to not be working at all.

I would appreciate any assistance figuring out what the cause of the problem is.

  • Paul
    • The Green Incsub

    2012-11-14 11:23:20: Notice: errno:8 Undefined variable: item_key D:inetpubuserscnorcrosswpmysqlwp-contentpluginssnapshotsnapshot.php on line 3687

    So the first error above is just where Snapshot defined a temp folder to be used be the PclZip library. This should be set to /wp-content/uploads/snapshots/_backup/<ITEM ID> Appears that the ITEM_ID is not properly being set or passed into the restore init function. Still it should not effect the restore since the PcLZIP temp folder will be assigned to the default tmp file location by PHP.

    2012-11-14 11:23:20: Warning: errno:2 mkdir(): Invalid argument D:inetpubuserscnorcrosswpmysqlwp-adminincludesclass-pclzip.php on line 5019

    The other error is from the PclZIP library where it attempt to create the path from the unzip processing.

    if (!@mkdir($p_dir, 0777))

    When Snapshot restore starts the first this that happens is the zip file is unzipped into the /wp-content/snapshots/_restore folder. You will see the .sql database dump files at this site root. Then any files will be in a www sub-folder. Can you tell me if these files are seen in the _restore directory?

  • Paul
    • The Green Incsub

    @terry,

    Looking into this more this morning I’ve patched the Notice error on the time_key not defined. Trying to see if this helps in the restore processing on your site.

    Can you please download the following beta for 2.0.5.1-Beta1

    https://dl.dropbox.com/u/2616987/WPMUDev/snapshot-2.0.5.1-Beta1.zip

    Hopefully this is not related to Windows paths vs UNIX. I don’t really have a Windows setup to test with. So hopefully you don’t mind providing details on your findings.

    Thanks.

  • Terry
    • Flash Drive

    @paul,

    I installed the beta version that you supplied (2.0.5.1-Beta1) and it did get rid of the time_key error.I am still getting the mkdir() errors and the restore is not happening.

    I looked in the “_restore” folder and it was empty with the exception of a dummy index.php file. (The actual path is /wp-content/uploads/snapshots/_restore not /wp-content/snapshots/_restore as you specified but I’m assuming that has nothing to do with the problem.)

    I’m attaching the backup/restore log file as well as a portion of our php error log file which contains some Snapshot related messages. Let me know if you need any other info.

  • Paul
    • The Green Incsub

    @terry,

    (The actual path is /wp-content/uploads/snapshots/_restore

    Correct. My fault for typing this out.

    Interesting on the errors. Going back to try and see if I can figure out what PcLZIP is complaining about. Hopefully will be back with some question or answers or both.

  • Paul
    • The Green Incsub

    @terry, Can you email me paul [at] incsub.com some details on your Windows setup. I think the only way I’m going to be able to solve this is getting my hands on a site running Windows and WordPress. I generally use a Mac for development but do have VMWare installed with Windows 7. I should be able to setup WordPress and get things running.

    But not sure on your setup.

    1. What is your web server? Are you running Apache on Windows or IIS?

    2. MySQL and PHP I’m assumed latest stable.

    3. Any other configurations I need to know about? Just trying to make sure my setup is compatible to yours. Apples to Apples.

  • Paul
    • The Green Incsub

    Well good new on progress. Was abl to get WP installed under my VMWare partition. Ran a snapshot just for file. When attempting the restore I’m getting the save errors. so will be able to investigate this. W00t!

    2012-11-15 22:06:09: file: wp-content/themes/twentyten/images/headers/sunset-thumbnail.jpg

    2012-11-15 22:06:09: file: wp-content/themes/twentyten/images/headers/sunset.jpg

    2012-11-15 22:06:09: file: wp-content/themes/twentyten/languages/twentyten.pot

    2012-11-15 22:06:10: finish: snapshot-1353017142-121115-220542-c3cc7056.zip

    2012-11-15 22:06:34: memory limit: 128M: memory usage current: 20.75M: memory usage peak: 20.75M

    2012-11-15 22:06:34: restore: init

    2012-11-15 22:06:34: Notice: errno:8 Undefined variable: item_key C:UsersPaul MenardDocumentsMy Web Siteswordpresswp-contentpluginssnapshotsnapshot.php on line 3687

    2012-11-15 22:06:34: Warning: errno:2 mkdir(): Invalid argument C:UsersPaul MenardDocumentsMy Web Siteswordpresswp-adminincludesclass-pclzip.php on line 5019

    2012-11-15 22:06:34: Warning: errno:2 mkdir(): Invalid argument C:UsersPaul MenardDocumentsMy Web Siteswordpresswp-adminincludesclass-pclzip.php on line 5019

    2012-11-15 22:06:34: Warning: errno:2 mkdir(): Invalid argument C:UsersPaul MenardDocumentsMy Web Siteswordpresswp-adminincludesclass-pclzip.php on line 5019

    2012-11-15 22:06:34: Warning: errno:2 mkdir(): Invalid argument C:UsersPaul MenardDocumentsMy Web

  • Paul
    • The Green Incsub

    @terry (Chris), Thanks! Glad this worked out. now that I have a Windows environment I can do better QAA for you Windows users. I know you always seems to be treated as secondary. Sorry about not testing prior.

    And or course let me know if you run into any other issues with Snapshot.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.