Site Search rewrite conflict with Social Plugins

I think the global_site_search_rewrite function of Global Site Search is rewriting URLs generated by Social plugins such as the Fixed Social Buttons plugin. That's my best theory anyway after just a glance at the code based on what is happening here:
http://clvr.tv/site-search/

That's quite a broad re-write rule. Maybe I'm drawing the wrong conclusion, but is there an easy way to fix the issue (other than disabling the Fixed Social Buttons plugin, which is not really a solution).

Seems like this issue would also occur in other instances when plugins or templates pass the current URL as a querstring parameter to links on the page (obviously a common occurrence when implementing social sharing links and scripts).

Many thanks for your time!

  • Andrew
    • Champion of Loops

    Hiya,

    We'll take a look at the plugin this week and see how we can modify the rewrite rules. Can you provide us with a link to the plugin your having issues with so we can grab a copy.

    That's quite a broad re-write rule

    I'm not quite sure what you're referring to. The rewrite rule only rewrites urls with the site-search page slug.

    Thanks,
    Andrew

  • ClvrTv
    • Site Builder, Child of Zeus

    Sure thing - issue seems to be between site-search and this plugin:

    http://wordpress.org/extend/plugins/fixed-social-buttons/

    I'm not quite sure what you're referring to. The rewrite rule only rewrites urls with the site-search page slug.

    Hmmm... maybe a bad assumption on my part. But I was basing it on observation of looking at the behavior and comparing the results between:
    http://clvr.tv (without site-search)
    (and)
    http://clvr.tv/site-search (with site-search)

    It seems like the site-search and fixed social buttons are colliding on <a href's from the fixed social buttons that include &title= in the querystring. Some buttons are fine/normal, but the ones that include &title= have been rewritten by the site-search plugin, thus breaking the HTML.

    Much appreciated!
    (also) Andrew

  • ClvrTv
    • Site Builder, Child of Zeus

    Sorry - maybe I don't quite understand your question. If you go to those two links above you will see an example of the urls being rewritten on the site-search page but not on the normal home.

    Just view the page source. It happens every time site-search loads...

    I wonder if maybe someone had disabled the Fixed Social Buttons or if an upgrade deactivated them. If you did already check those links and nothing looked wrong I apologize. The plugin has been re-activated, please check again.

    You should see a vertical row of social buttons on the far right of the page. On the site-search page some of these buttons are missing and re-written text gets inserted instead at the top of the page.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.