Site Slowdown/Hummingbird, WordPress, or Site Server?

Hey There!
Maybe this isn't a question for you guys, so I am sorry if this is off topic. Sometimes when I am working on my site and especially when I am adding media, it seems like my internet is sooooo slow. It says "waiting for [mywebsite]", but when I go to google or some other public web address it goes lightening fast! Is this problem with WordPress, my cache, or with my host server?
Thanks!
Jane

  • James Morris
    • WordPress Enthusiast

    Hello Jane,

    I hope you are well today.

    I just checked your site out a bit (beautifully done, by the way!). I browsed your site here in the Eastern US and I ran it through https://gtmetrix.com/ and https://tools.pingdom.com/ I'm not seeing anything that's sticking out. The site loads quickly for me. There are some minor issues with http->https redirects, browser caching and such. But nothing that would cause a significantly slow load time.

    Have you tried accessing the site on a different network. Perhaps using a 4G mobile connection or accessing it from a computer on a different network. Are you still seeing slow load times then?

    Best regards,

    James Morris

  • Jane
    • New Recruit

    Hey There James!

    Thanks for the response and for checking out my site. I'm a total newbie at this, so the compliment is like gold :slight_smile: As far as running it on other networks - it seems like it is most slow when I am working on my site. It's not a huge deal by any means but was just wondering if it was something I should talk to my server hoster guy (aka my brother) about.

    Thanks!
    Jane

  • James Morris
    • WordPress Enthusiast

    Hello Jane,

    Sure thing. Thanks for clarifying when you're seeing the problem. In order to help you better with your issue, would you please grant me access to your site? I can take a look at the backend response times and see if there's something there.

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • Jane
    • New Recruit

    Hi Again!

    I just granted access. Maybe it won't be going slow for you, in which case I'll assume it's just my internet being wonky. I often have trouble with "adding media" or waiting for previews to load.

    Anyhow, thanks for all of the help. Lemme know what you find when you have a chance.

    Best,
    jane

  • James Morris
    • WordPress Enthusiast

    Hello Jane,

    I took a good look over your site and I'm not really seeing any slow load times on the backend. Everything seems to be performing normally given the resources available to your site. However, I did observe some fairly easy ways you could improve performance. Please see the following screenshots and suggestions.

    http://storage4.static.itmages.com/i/18/0306/h_1520317263_8608552_d0800ccbcc.png

    As you can see in the above screen, your max_execution_time and memory_limit values are fairly low. Most hosts will allow you to increase these values. You may need to consult with your particular hosting provider's documentation in order to increase these through either cPanel, Plesk, php.ini or .user.ini, but here are some recommended values.

    max_execution_time = 180
    memory_limit = 512M

    Also, I'm seeing that you are running on PHP 5.6. While this version of PHP is well supported, upgrading to PHP 7.x would yield significantly better performance overall. PHP 7 includes native object caching, is more secure, and generally is magnitudes faster than PHP 5.6.

    http://storage6.static.itmages.com/i/18/0306/h_1520317295_7097571_dc73054687.png

    As you can see in the above screen, WordPress is not configured to make the most of what resources are available to it. Currently you can define up to 256M available to the WordPress frontend. This can improve responsiveness for visitors and help your site accommodate more visitors. You can increase this value by doing the following:

    Please add the following define in wp-config.php right above the / That's all, stop editing! Happy blogging. / line.

    // Increase WP Memory Limit
    define('WP_MEMORY_LIMIT', '256M');

    Note: If you increase your PHP memory_limit, you can also update the WP_MEMORY_LIMIT to match what is set in PHP.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.